Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Извлечь из перода даты с заданным днем недели
 
привет,
В ячейках A1 и B1 по дате четверг свои дни, я хочу найти.
 
Найти даты, попадающие в период? В файле.
 
vikttur,
D1: D9 диапазон авто надо искать.
Результаты вы видели, чтобы я написал.
A1 и B1 в соответствии с
 
автору видимо нужно выводить из заданного диапазона дат - список дат, если день недели = четверг
вот макрос:
Код
Sub Thursday()
Dim d As Date
Dim i As Long
i = 1
For d = Cells(1, 1) To Cells(1, 2)
    If Application.WorksheetFunction.Weekday(d, 11) = 4 Then '11 means first day of week is monday (thursday then is 4th)
        Cells(i, 4) = d
        i = i + 1
    End If
Next d
End Sub
Изменено: anyarceva - 6 Мар 2015 15:21:46
 
Можно это сделать и таким способом.
 
Вариант:
=A1+C1-ВЫБОР(ДЕНЬНЕД($A$1;2);1;2;3;4;-2;-1;)
=ЕСЛИ(D1="";"";ЕСЛИ(D1+7>$B$1;"";D1+7))
 
anyarceva,jakim,vikttur
Спасибо. Для меня очень хорошо.
 
Аnyarceva, помоги пожалуйста с макросом нужно выводить из заданного диапазона дат - отдельно КОЛИЧЕСТВО, ПН,ВТ,ЧТ,ПТ,СБ,ВС

Изменено: Vous - 9 Май 2015 14:43:52
 
Vous, свой пример что есть и что хотите увидеть в файле до 100 кб
Лень двигатель прогресса, доказано!!!
Страницы: 1
Читают тему (гостей: 1)