Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Использование формулы массива для поиска по нескольким условиям
 
Господа знатоки, прошу помощи, никак не пойму, в чем проблема.
Использую формулу массива для поиска данных по нескольким условиям.
При том, что есть все данные и они все одного формата, некоторые данные определяются, а некоторые нет.

1 скрин - ошибка
2 скрин - данные
3  сам файл.
Взываю к помощи!))

Рисунки удалены: превышеyие допустимого размера вложения [МОДЕРАТОР]
 
Посмотрите здесь, может что-то похожее и надо округлять. ВПР и дата
Работать надо не 12 часов, а головой.
 
Сделайте timestamp'у текст по столбцам - готово.
 
Не могли бы вы прояснить, что именно сделали? Не вник(
 
Выделил столбец, далее в меню Data->Text to columns - >Finish
 
Код
=ИНДЕКС(Data!D$2:D$11757;ПОИСКПОЗ(G2&ТЕКСТ(H2;"ч:м:с");Data!A$2:A$11757&ТЕКСТ(Data!C$2:C$11757;"ч:м:с");0))
Excel 2013
 
Цитата
Hugo написал: Выделил столбец, далее в меню Data->Text to columns - >Finish
Спасибо огромное!
Вот только не могу до конца понять логику этих действий, на будущее.
Если не сложно поделитесь, в чем была проблема, и почему решается именно так)
 
Ну это равносильно тому, как зайти в каждую ячейку и нажать enter. Очевидно эти данные попали на лист в процессе импорта или экспорта из внешнего источника.
 
Попросту примените ко всем столбцам со временными данными например формулу
Код
=ROUND(B2;5)
 
Hugo, да, это так, спасибо большое!
Страницы: 1
Читают тему (гостей: 1)