Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Удалить значение ячейки при условии
 
Здравствуйте!
Прошу помощи.

Дано: столбец А - текст, который набирается вручную. Столбец Б - да\нет.
Требуется: в случае, когда в столбце Б стоит "да", удалить текст именно в этой ячейке столбца А.
То есть, если Б1 = "да", весь текст в А1 удаляется.
Не макросом!!

Спасибо!
 
и как Вы себе это представляете?
Учимся сами и помогаем другим...
 
Вот и спрашиваю...
Можно не удалить, а заменить на другой определенный текст, скажет "Данных нет".
Изменено: anat - 9 Мар 2015 19:18:59
 
Код
=ЕСЛИ(B1="Да";"";"Какой-то текст")
Еще можно условное форматирование применить. См вложение.
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
Нет, такое только макросом возможно.
Работать надо не 12 часов, а головой.
 
The_Prist, меняться должно содержимое ячейки А1.

Leanna, а как? И еще вопрос: этой таблицей будут пользоваться люди на других компах, макросы будут работать? Файл хранится в сети.
 
мож так пойдет меняйте в столбце Б да нет
Изменено: Сергей - 9 Мар 2015 13:53:41 (пока варганил пример Дмитрий уже выложил тоже УФ)
Лень двигатель прогресса, доказано!!!
 
The_Prist, условное форматирование - увы, клиент требует удалить данные.
 
Сергей, увы, как раз ответила выше
 
Макросы будут работать если они их включат. По умолчанию вроде обычно безопасность выставлена отключать макросы.
Если хотите макросами прикладывайте файл-пример.
Работать надо не 12 часов, а головой.
 
Цитата
anat написал: увы, клиент требует удалить данные
Увы, тогда Вы должны отказать клиенту, потому как без макросов удалить данные в ячейках нельзя. Пусть тогда при выборе "Да" удаляет сам руками.
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
Понятно...
Спасибо всем!
Страницы: 1
Читают тему (гостей: 1)