Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Массив: вставить информацию в каждую строку, не учитываем пустые строки
 
Добрый день.
Может не в этой ветке, но все же хотел бы попросить помощи.
1. Есть формула массива: =ЕСЛИ(B3:B192>0;ЕСЛИОШИБКА(ИНДЕКС(B$3:$B$192;НАИМЕНЬШИЙ(ЕСЛИ($AF$3:$AF$192="да";СТРОКА(B3:B192)-2;"");СТРОКА()-2));"");"")
Но в ней есть один минус для меня, она учитывает пустые строки, создавая пустые строки в том диапазоне куда я учитываю информацию, мне нужно чтобы массив вставлял информацию в каждую строку.
Диапазон выделил желтым цветом.

Буду рад любой помощи
Изменено: Aka47 - 10 Мар 2015 17:36:29
 
не совсем понятно чем не устраивает формула диапазоны закрепить и по мне дак нормально работает
Лень двигатель прогресса, доказано!!!
 
Закрепил области, но он все равно не пропускает пустые строки.
Даже в Вашем файле пробую тоже самое и все равно не так...
в чем секрет...
Изменено: Aka47 - 10 Мар 2015 13:07:07
 
Ну вы бы файлик выложили с ошибкой можно было бы посмотреть а так не понятно что не так вообще можно не массивными вытащить если доп столбец сделать
Лень двигатель прогресса, доказано!!!
 
Вот я рядом вставил ту же формулу и работает как прежде у меня учитывая пустые строки...
Плюс по второму вопросу, может есть какие идеи?
 
Вы её пытаетесь ввести для определенного массива строк а нужно вводить в 1 ячейке и растягивать вниз по строкам
Изменено: Сергей - 10 Мар 2015 17:11:29
Лень двигатель прогресса, доказано!!!
 
Точно :)))), большое спасибо.
Страницы: 1
Читают тему (гостей: 1)