Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Целое и дробное значение
 
Добрый день!
Возник вопрос, как в условии ЕСЛИ сделать зависимость от результата деления (целое или дробное значение). К примеру: если результат A1/B1 - целое число, то выполняется такое-то условие ЕСЛИ, если результат деления - дробное число, то будет выполняться другое условие.
 
=ЕСЛИ(ОСТАТ(A1/B1;1);_дробное_;_целое_)
 
Код
=если(остат(A1/B1;1);"Дробное_число";"Целое_число")


зы. из-за особенностей вычислений возможны нюансы, поэтому надежнее так:
Код
=ЕСЛИ(ОКРУГЛ(ОСТАТ(A1/B1;1);8);"Дробное_число";"Целое_число")
Изменено: Михаил С. - 11 Мар 2015 10:46:21
 
Большое спасибо! Всё заработало как надо
Страницы: 1
Читают тему (гостей: 1)