Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Подсчет среднего в поддиапазоне
 
Здравствуйте!
Задача состоит в том, чтобы посчитать среднее для куска диапазона, ограничивающийся числами, указанные пользователем в окнах "От" и "До"
То есть, среднее считается по столбцу "Значения", а ограничивается по столбцу "Сутки".
Если пользователь "не попал" в точное значение "Суток", то значения берутся для нижней границы больше или равно, а для верхней - меньше или равно.
Помогите, пожалуйста.
Спасибо!
 
как макросом не знаю формулами можно реализовать так
Лень двигатель прогресса, доказано!!!
 
Сергей, немножко не поняла, как работают в формуле аргументы "Отсель, досель"..
 
Ctrl+F3
Смотрите имена и формулы
 
vikttur, спасибо!
 
Oda412, тама спрятаны такие
Код
=ИНДЕКС(Лист1!$B$2:$B$40;ПОИСКПОЗ(МАКС(ЕСЛИ(Лист1!$A$2:$A$40<=Лист1!$E$1;Лист1!$A$2:$A$40));Лист1!$A$2:$A$40;0))
=ИНДЕКС(Лист1!$B$2:$B$40;ПОИСКПОЗ(МИН(ЕСЛИ(Лист1!$A$2:$A$40>=Лист1!$D$1;Лист1!$A$2:$A$40));Лист1!$A$2:$A$40;0))
Лень двигатель прогресса, доказано!!!
Страницы: 1
Читают тему (гостей: 1)