Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
С помощью массива поднимать значение в пустую ячейку
 
Добрый день.
Подскажите, как допилить формулу, чтобы в столбце не было пустых ячеек. (вкладка "общая")
Заранее спасибо.
Изменено: Aka47 - 11 Мар 2015 13:53:52
 
Обязательно формулы? Сводная не подойдёт?
 
Если нормализовать данные (что рекомендую), то с помощью сводных таблиц можно разные отчеты формировать
Согласие есть продукт при полном непротивлении сторон.
 
Спасибо за советы, но эти страницы тянутся еще из другого документа.
Поэтому хотел сделать автоматически без фильтрации и без пробелов, просто консолидированную заявку.
 
Раз сводные не устраивают пробуйте так
Лень двигатель прогресса, доказано!!!
 
Огромнейшее спасибо.
Формула ЧУМА.
 
можно чуть сократить убрав обработку ошибок которые у вас скрыты в столбце F (а я бошку ломал че у меня знач лезет)
Код
=ИНДЕКС('по блюдам'!$C$3:$C$17;НАИМЕНЬШИЙ(ЕСЛИ((СЧЁТЕСЛИ('общая '!$C$2:C2;'по блюдам'!$C$3:$C$17)=0)*('по блюдам'!$F$3:$F$17<>"");СТРОКА('по блюдам'!$F$1:$F$15));1))
Лень двигатель прогресса, доказано!!!
Страницы: 1
Читают тему (гостей: 1)