Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Подборка чисел из таблицы для вычисления приблизительного значения
 
Доброго времени суток.
Во вложенном файле есть таблица 3 столбца 6 строк , прошу помочь в написании формулы:
Необходимо из каждой строки методом подбора выбрать одно число , т.е. будет отдельно 6 числе и потом перемножить их получить значение которое мы ищем
1-2-3
2-3-3
1-3-3
1-4-3
1-4-5
1-1-1
например нам нужно значение 2 , выборка выдала  будет 1*2*1*1*1*1,  и выкладывало все варианты таких значений  возможно примерные т.к. работа будет так  десятич.
цифрами.

2) также необходимо что выборка искала число при суммирование данных  т.е. нужно число 7 итог 1+2+1+1+1+1

буду  благодарен помощи.
 
ничего не понятно, пример один, а описание совсем другое. Что, откуда, какое правило?
из такого описания можно предлодить и вариант:
Код
=ПРОИЗВЕД(A1:A6)
=СУММ(A1:A6)
 
т.е из ниже указанной таблицы мне необходимо найти число близкое к 148 с возможно погрешностью +5 -5
а найти его путем перемножения только одного значения из каждой строки
допустим 1,17*2*1,4*1,62*1,78*2,3
в данной таблице 729 комбинаций в общем вот из 729 комбинаций нужно как то сделать выборку чтобы выдала программа только те комбинации где  число близкое к 148
1,176,5021,00
2,003,204,00
1,404,337,00
1,623,606,00
1,703,805,75
2,303,403,40
 
задача решается полным перебором, количество вариантов 3^6 (очень даже не много)
На VBA не сложно реализовать.
Какова реальная таблица, также 3х6 или больше?
 
реальная таблица 3 на 6, а можно пожалуйста подробнее  , т.к. можно сказать отношусь к категории новичков
 
как то так
 
СПАСИБО , СПАСИБО.
благодарность с меня на
Z144933915287 ? правильно?
Страницы: 1
Читают тему (гостей: 1)