Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Вывод значения ячейки строки при двух совпадениях одновременно, помощь
 
Добрый день, гуру Excel помогите пожалуйста с примером:

Есть закладка (DATA) содержит код товара столбец 1 и номер товара столбец 2, код товара может быть одинаковый у нескольких строк, номер товара присвоен каждой строке уникальный.
Есть отдельная закладка(OPISANIE) с такими же 2-мя столбцами (повторяющимися), но с описанием товара(артикулом) и количеством.
Задача:

При совпадении одновременно кода товара и номера товара в закладках DATA и OPISANIE,  вывести значение артикула и количества из закладки OPISANIE в закладку DATA напротив совпавшего значения.
Пробовал ИНДЕКС ПОИСКПОЗ не получилось...
Помогите...
Пример приложил
 
Цитата
Daniel604 написал: номер товара присвоен каждой строке уникальный.
врёте же. у кода 10130010/090215/0002478 четырнадцать раз номер товара 1. И какой из них брать?
Доп. столбец допустим?
Изменено: V - 11 Мар 2015 20:24:33
 
В закладке DATA, нет значения 1, его просто не выводим никуда (если его нет), ищем только совпадения.
Но если усложнить задачу и всетаки в  DATA будет 1 то вывести все артикулы с значением 1 в описание (через запятую)
Изменено: Daniel604 - 11 Мар 2015 20:24:45
 
если считать список на листе opisanie уникальным, то можно так
 
Цитата
Daniel604 написал: то вывести все артикулы с значением 1 в описание (через запятую)
в этом случае UDF поможет. поищите VLOOKUPCOUPLE_spec
по поводу доп. столбца что скажите?
 
пока формула массива
Код
=ИНДЕКС(OPISANIE!$C$2:$C$96;ПОИСКПОЗ(DATA!A2&DATA!B2;OPISANIE!$A$2:$A$96&OPISANIE!$B$2:$B$96;))
во вторую ячейку по аналогии.
 
Цитата
webley написал: если считать список на листе opisanie уникальным, то можно так
Спасибо webley , если уникально, то выводит.
Вопрос с UDF теперь , если много значений допустим 1 ,как все артикулы вывести или через пробелы или запятую.
Попробую UDF посмотреть
 
V - Cпасибо!
Сложный вариант буду читать UDF
 
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
Приложил сложный вариант:oops:
В OPISANIE много значений совпадающих, все артикулы надо писать в 1 ячейку через запятую или пробел.
В DATA всегда значения оригинальны.
 
Точно, работает
Код
=VLOOKUPCOUPLE_spec(OPISANIE!$A$2:$D$96,1,2,A2&"|"&B2,3,",")
и
=VLOOKUPCOUPLE_spec(OPISANIE!$A$2:$D$96,1,2,A2&"|"&B2,4,",")
Если будут повторы - покажет все через запятую.
Изменено: Hugo - 11 Мар 2015 18:56:15
 
Цитата
Hugo написал:
=VLOOKUPCOUPLE_spec(OPISANIE!$A$2:$D$96,1,2,A2&"|"&B2,4,",")
Не смог в пример вставить, ошибку дает :(
 
Цитата
V написал: поищите VLOOKUPCOUPLE_spec
Daniel604, читаем внимательно, пользователь V, посоветовал поискать, неужели поиск по форуму ничего не дает? я например находил данную UDF.
 
Берите код из любой темы:
http://www.planetaexcel.ru/forum/index.php?PAGE_NAME=search&tags=&q=VLOOKUPCOUPLE_spec
 
Нашел, заработало! Спасибо огромное всем!!
Страницы: 1
Читают тему (гостей: 1)