Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
сведение строк в одну по нескольким критериям
 
Доброго дня! Нужна помощь!

Есть таблица . Нужно проставить нумерацию в столбце POS так, чтобы она была одинаковой в строках с одинаковыми значениями в столбцаз DIA КЛАСС и LARM

Файл прилагаю. Спасибо за любую помощь!
 
В первой строчке поставить 1 вручную, в остальных формула
Код
=ЕСЛИ(И([@DIA]=E2;[@КЛАСС]=F2;[@LARM]=H2);C2;C2+1)

Изменено: МВТ - 12 Мар 2015 22:45:07 (Добавил файл, все время забываю)
 
Спасибо. Но вот я поменял в одном месте LARM и у меня получилось две схожие строки в середине и в конце. И они получают разное значение POZ, что не годится
 
МВТ, а для чего нужны значки @ в вашей формуле? Что они означают? Поискал в интернете, не смог найти.
 
Попробуйте так, правда пришлось сделать дополнительный столбец.  Newbie, "@" значит, что я беру соответствующее значение из поля таблицы
Код
=ЕСЛИ(ПОИСКПОЗ([@Столбец1];$I$2:I2;0)=СТРОКА();СТРОКА()-1;ПОИСКПОЗ([@Столбец1];$I$2:I2;0))

Изменено: МВТ - 12 Мар 2015 23:35:48 (Исправил опечатку)
 
На первый взгляд работает. Спасибо. Я покатаю ещё
Покатал ииии...
Пропускаются значения при нумераци POZ, а мне надо чтобы нумерация была без пропусков!((
Изменено: mixtaper - 12 Мар 2015 23:52:01
 
mixtaper,расскажите потом как работает, если не сложно
 
Написал выше , есть недочет... важный для меня
 
Скиньте где пропускает, если не сложно
 
МВТ, а зачем =ЕСЛИ()? почему не просто =ПОИСКПОЗ([@Столбец1];$I$2:I2;0) ?
 
Воот
2015-03-14_1526.png (24.23 КБ)
 
да... а если одинаковых строк подряд больше, чем 2, Ваша формула также вернет неправильный счет :(
 
Попробовал по другому: в первой строчке прописать 1, в остальных
Код
=ЕСЛИ(ПОИСКПОЗ([@Столбец1];$I$2:I3;0)=СТРОКА()-1;МАКС(C$2:C2)+1;ПОИСКПОЗ([@Столбец1];$I$2:I3;0))

По крайней мере, 3-ка появилась, не знаю, как будет с другими номерами )))
 
У меня вот такая формула получилась
=ЕСЛИ(ЕНД(ПОИСКПОЗ($I2;$I$1:$I1;0));МАКС(C$1:C1)+1;ИНДЕКС(C$1:C1;ПОИСКПОЗ($I2;$I$1:$I1;0)))
или она же
=ЕСЛИ(ЕНД(ПОИСКПОЗ([@Столбец1];$I$1:$I1;0));МАКС(C$1:C1)+1;ИНДЕКС(C$1:C1;ПОИСКПОЗ([@Столбец1];$I$1:$I1;0)))
Изменено: Михаил Лебедев - 14 Мар 2015 18:31:43
 
Забыл сказать , спасибо...
все работает
 
Код
=ЕСЛИ(СТРОКА()=СТРОКА(Таблица1[#Заголовки])+1;
      1;
      ЕСЛИ(ЕНД(ПОИСКПОЗ([@CORT];ИНДЕКС([CORT];1):СМЕЩ([@CORT];-1;0);0));
           МАКС(ИНДЕКС([POS];1):СМЕЩ([@POS];-1;0))+1;
           ИНДЕКС(ИНДЕКС([POS];1):СМЕЩ([@POS];-1;0);ПОИСКПОЗ([@CORT];ИНДЕКС([CORT];1):СМЕЩ([@CORT];-1;0);0))
           )
      )
Ради интереса решил переделать в нотации этих "умных ссылок", выглядит громоздко, может кто-то упростит?

 
Изменено: mentalzorro - 3 Апр 2016 12:21:19
Страницы: 1
Читают тему (гостей: 1)