Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Подсчет уникальных значений в столбце при условии,что количество одинаковых уникальных значений больше 13
 
Добрый вечер, уважаемые форумчане. Прошу вашей помощи в совершенствовании формулы, что осуществляет подсчет количества уникальных значений в столбце.  Сейчас я использую формулу масива: =СУММ(ЕСЛИ(ЕПУСТО(B3:B2500);0;1/СЧЁТЕСЛИ(B3:B2500;B3:B2500)))
Она считает все уникальные значения в диапазоне.
Как формулу изменить так, чтобы она считала количества уникальных значений при условии, если количество одинаковых значений более 13.

Заранее огромное спасибо.
 
Код
=ЕСЛИ(СЧЁТЕСЛИ(B:B;M2)<=13;0;СЧЁТЕСЛИ(B:B;M2))
 
Спасибо огромное, B.Key
Данные в колонке М не нужно использовать.
В результате в ячейке J3 должно быть 3.
То есть в диапазоне уникальных значений колонки В: В всего три уникальные значения, количество которых более 13.
Для визуального понимания здесь на сайте  я это изобразил в M2:N6 но его нет.
Нужно с помощью формулы в J3 вывести результат подсчета.
Заранее огромное спасибо.
 
Мо быть - варианты для ленивых?.. ;)
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Zспасибо огромное за вариант сводной й фильтра.
В моем файле нужно только результат в J3, потому что все остальные ячейки заняты цифрами. Отчет очень большой в 10000 заполненных срок.
Любые другие результаты не нужны (по эксп. и количеству).
Наверное нужно как-то использовать формулу массива =СУММ(ЕСЛИ(ЕПУСТО(B3:B2500);0;1/СЧЁТЕСЛИ(B3:B2500;B3:B2500))) но в ней внести одно условие, что данный подсчет уникальных в В:В проводится, если количество одинаковых значений в колонке более 13.
Огромное Вам спасибо за помощь и советы. Дай Бог здоровья.
 
Уважаемые форумчане.
Возможно Вы знаете как это макросом как нибудь сделать.
 
Ну добавьте условие больше 13 в формулу, в чем сложность?
ФМ:
Код
=СУММ(ЕСЛИ(ЕПУСТО(B3:B2500);0;(1/СЧЁТЕСЛИ(B3:B2500;B3:B2500))*(СЧЁТЕСЛИ(B3:B2500;B3:B2500)>13)))
 
Здравствуйте, форумчане. Возникла такая же необходимость как в данном форуме: Подсчет уникальных при условии, что количество уникальных более 7.
Для этого я использую формулу массива с данного форума:
Код
=СУММ(ЕСЛИ(ЕПУСТО(ОТЧЕТ!A$2:A$25000);0;(1/СЧЁТЕСЛИ(ОТЧЕТ!A$2:A$25000;ОТЧЕТ!A$2:A$25000))*(СЧЁТЕСЛИ(ОТЧЕТ!A$2:A$25000;ОТЧЕТ!A$2:A$25000)>7)))
Однако при осуществлении вычислений данная книга "зависает" намертво на 10 минут, а затем при последующих любых вычислениях в книге все время срабатывает вычисления ячеек и книга снова "зависает" на минуту.
На данном сайте я нашел макрос который вычисляет количество уникальных:
Код
Public Function CountUnique(rng As Range) As Long
    Dim myCell As Range
    Dim UniqueVals As New Collection
    Application.Volatile
    On Error Resume Next

    For Each myCell In rng
        If Not IsEmpty(myCell) Then UniqueVals.Add myCell.Value, CStr(myCell.Value)
    Next myCell
    On Error GoTo 0
    CountUnique = UniqueVals.Count
End Function
Помогите пожалуйста в данном макросе прописать условие подсчета уникальных значений -подсчет уникальных осуществляется, если количество уникальных значений более 7.
Заранее огромное спасибо всем.
 
Сделал так:
Код
Sub Uniq()
'
    Application.ScreenUpdating = False
    Application.Calculation = xlCalculationManual
    Application.EnableEvents = False
    Application.DisplayAlerts = False
    Range("D5").Select
    Selection.FormulaArray = _
        "=SUM(IF(ISBLANK(ОТЧЕТ!R2C[-3]:R25000C[-3]),0,(1/COUNTIF(ОТЧЕТ!R2C[-3]:R25000C[-3],ОТЧЕТ!R2C[-3]:R25000C[-3]))*(COUNTIF(ОТЧЕТ!R2C[-3]:R25000C[-3],ОТЧЕТ!R2C[-3]:R25000C[-3])>7)))"
    Selection.Value = Selection.Value
    Application.ScreenUpdating = True
    Application.Calculation = xlCalculationAutomatic
    Application.EnableEvents = True
    Application.DisplayAlerts = True
End Sub
Работает быстрее.
Страницы: 1
Читают тему (гостей: 1)