Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Как изменить окончания городов?, Нужно изменить окончания, пример в Москва - в Москве
 
Здравствуйте! Ребята, подскажите пожалуйста как можно формулой поменять окончания в списке городов - в Москва - в Москве. Пример прикрепляю!
Заранее большое Вам спасибо!!!!
 
но это не выход все равно проверять надо а то получится в тюмене, перме, чебоксаре
Код
=ЕСЛИ(ИЛИ(КОДСИМВ(ПРАВСИМВ(A16;1))=224;КОДСИМВ(ПРАВСИМВ(A16;1))=238;КОДСИМВ(ПРАВСИМВ(A16;1))=251;КОДСИМВ(ПРАВСИМВ(A16;1))=252);ЛЕВСИМВ(A16;ДЛСТР(A16)-1)&"е";A16&"е")
Лень двигатель прогресса, доказано!!!
 
off
А исхитриться "по старым правилам" русского языка не проще - в городе Москва?!
ps Файл не смотрел.
Изменено: Z - 15 Мар 2015 13:56:19
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
А исключения будут?  Вроде:
Суздаль
Улан-Удэ
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
для вашего файла - как то так.
либо вариант2 - создать словарь падежей и брать оттуда.
общий принцип тот же - перечисляете правила, либо в формуле, либо на листе.
 
В Кемеровской области есть город Яя ))
 
Уважаемая zaychenko_irina!
Полагаю, Ваш список названий городов представлен городами, с которыми работает Ваша организация.
В таком разе Вам будет намного "дешевле" этот список вести в "рукопашном" варианте.
См. ссылку:Склонение географических названий в русском языке
 
Dima S, СПАСИБО ВАМ БОЛЬШОЕ!!!! КРУТАЯ формула!!!! Большое Вам спасибо!!!
И всем Вам ребята большое спасибо, что откликнулись и помогли!!!  
Страницы: 1
Читают тему (гостей: 1)