Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Вынесение последнего кода из строки
 
Очень нужна помощь!
Есть определенный перечень  из которого нужно последний код (если такой имеется) вынести в отдельную ячейку, Таблица огромная - это пример. Заранее спасибо.
Втулка
 разжимного кулака МАЗ 5336-3502126 29.32.302000.01441
Втулка
 ЦГ80-280-3405032
Диск ведомый в
 сборе 182.1601130 29.32.306500.00072
Диск ведомый в
 сборе 184.1601130-10 29.32.306500.00075
Диск нажимной
 с кожухом в сборе 183.1601090 29.32.306500.00172
Диск сцепления
 ЯМЗ универсальный 238-1601130УТ 29.32.306500.00092
Заклепка 5х12
 (1 кг.) 255923
Заклепка 8х12
 (1 кг.) 336610
Замок
 зажигания 2101.3704000 29.31.303000.00039
Камера
 тормозная передняя тип 30 30.3519010-50 29.32.302000.00189
Камера
 тормозная с пружинным энергоаккумулятором в сборе (тип 24/24) 100-3519200-10
 29.32.302000.00154
 
Последний код всегда 18 символов
 
Думаю без пример данных в файле и более подробного описания решения не будет.
Вот например по этим данным - в скольких ячейках это забито? Может в одной? Или в 11 строках? В одном или в двух столбцах?
 
Вот UDF-ка исходя из того, что предоставлено:
Код
Public Function GetCode$(str$)
    Dim temp$()
    temp = Split(str, " ")
    If temp(UBound(temp)) Like "29." Then
        GetCode = temp(UBound(temp))
    Else:
        temp = Split(str, Chr(160))
        If temp(UBound(temp)) Like "29.*" Then
            GetCode = temp(UBound(temp))
            Exit Function
        End If
        GetCode = ""
    End If
End Function
С уважением,
Федор/Все_просто
 
Одной строкой (Название, каталожный номер, код)
Втулка разжимного кулака МАЗ 5336-3502126 29.32.302000.01441
 
Код не всегда начинается на 29 он всегда разный
 
Вы хотя бы часть файла покажите, а не на пальцах объясняйте.
 
Код
=ПРАВСИМВ(A1;18)
 
Может чуть понадёжнее
Код
=IF(LEFT(RIGHT(A1,19),1)=" ",RIGHT(A1,18),"")
Ещё бы проверить что внутри нет пробелов, и что если есть точки...
 
Код
=ЕСЛИОШИБКА(ПСТР(A1;ПОИСК("??.??.??????.?????";A1);18);"")
F1 творит чудеса
 
RAN, Спасибо за формулу, подходит, но только если есть код.
 
ВСЕМ, ВСЕМ ОГРОМНОЕ СПАСИБО!!!
 
RAN, Код переносится но и в предыдущей ячейке остается(((
 
Интересно смотреть, как трансформируется задание на глазах) А файла так и нету...)
 
Файл был, почему-то пропал... Ничего там секретного вроде не было.
Лучше всего отработала формула Максима (вероятно, полностью не проверил за неимением 2007+), моя вытянула одно лишнее значение.

Pchela_ola - функции не могут ничего перенести, они только копируют.
 
Влад,  
Втулка разжимного кулака МАЗ 5336-3502126 29.32.302000.01441 - ЭТО ОДНА ЯЧЕЙКА, НУЖНО КОД ПЕРЕНЕСТИ В ДРУГУЮ ЯЧЕЙКУ.
 
Pchela_ola,
КОД  КОТОРЫЙ НУЖНО ПЕРЕНЕСТИ - ВСЕГДА 18 СИМВОЛОВ, НО ЦИФРЫ РАЗНЫЕ.
 
ТОЛЬКО ЗАРЕГИСТРИРОВАЛАСЬ НА ВАШЕМ САЙТЕ, ПОЭТОМУ МОЖЕТ ЧЕГО НЕ ПОЛУЧАЕТСЯ)))) ЕСЛИ ЧТО - ИЗВИНИТЕ)))  
 
Для ячейки H4:
Код
=ЛЕВСИМВ(B4;ЕСЛИОШИБКА(ПОИСК("??.??.??????.?????";B4)-1;ДЛСТР(B4)))

Для ячейки J4:
Код
=ЕСЛИОШИБКА(ПСТР(B4;ПОИСК("??.??.??????.?????";B4);18);"")

протянуть формулы вниз.
Проверяйте в файле
F1 творит чудеса
 
Максим Зеленский,
ОГРОООООМНОЕ ВАМ СПАСИБО. ВЫ ВОЛШЕБНИК))))!!!! Все работает!!!!
 
Hugo, Максим Зеленский, Влад, Юрий М, Все_просто, RAN,
Огромнейшее спасибо ребята!!!
 
Предлагаю для ячейки J4:
Код
=ПОДСТАВИТЬ(B5;H5;"")
Страницы: 1
Читают тему (гостей: 1)