Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Как сделать чтобы время выводилось в формате 00:00:00:00, а не 0:00:00:00?
 
Доброго времени суток!
Помогите пожалуйста.
Не особо силен в Excel.
Значит ситуация такая...
К нам приходят плей-листы с московским временем в формате
22:00:03:00
22:25:10:15
23:34:15:19
23:40:15:19
00:21:12:12
и т.п.
Необходимо перевести все время на 2 часа вперед, то есть
00:00:03:00
00:25:10:15
01:34:15:19
01:40:15:19
02:21:12:12
Подскажите пожалуйста как это можно сделать?
Спасибо!

P.S. Погуглив, пока что ничего лучше не придумал, как использовать функцию ЛЕВСИМВ и прибавлять к ней 2.
Затем ЕСЛИ значение ячейки = 25 то 01, если 24 то 00.
Причем ноль впереди 1 и 0 выводится, только если заключать в кавычки, соответственно выравнивание в ячейке влево, а у цифр вправо ...
Как сделать чтобы время выводилось в формате 00:00:00:00, а не 0:00:00:00?
Может быть есть нормальный способ (VBA не предлагать) без использования промежуточных ячеек?
Такой, чтобы девушки, формирующие плей-листы, как можно меньше заморачивались, и оперативно меняли столбик со временем со смещением +2 часа.
Еще раз спасибо, всем откликнувшимся.
P.P.S. На всякий случай загрузил аттач. А то может коряво выразился
 
=ТЕКСТ(ЛЕВСИМВ(B3;8)+"2:00";"чч:мм:сс")&ПРАВСИМВ(B3;3)
Изменено: Михаил С. - 18 Мар 2015 20:20:27
 
Михаил, спасибо Вам огромное за оперативность! Чрезвычайно признателен
 
Если не ошибаюсь, то просто к своему времени (только в формате Время, а не текст, как в прикрепленном файле) к исходному времени прибавьте 1/12 и получите нужный результат  
Страницы: 1
Читают тему (гостей: 1)