Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Суммирование значений из разных листов
 
Здравствуйте!
Может сможет кто-то из мудрых екселистов помочь с таким вопросом:)
Как сделать, чтобы со второго листа количество товара по городам переносилось в первую таблицу (они отличаются по наполнению), суммируя одинаковые значения по строчкам? Т.е. количество касок из листа № 2 из Подольска, Дубны и Химок просуммировать с касками на листе № 1 в Подольске, Дубне и Химках и сумму там же и отобразить на первом листе.
И значения, которые не перенеслись, как можно выделить? Или перенесенные обнулить? Чтобы потом их руками переносить.
ПС: в файле под 4000 строчек и столбцов около 20 на каждом листе...
Спасибо!!
 
Цитата
bug написал:  и сумму там же и отобразить на первом листе.
в одной и тойже ячейке? О_о
 
На деле вообще ничего не понятно, что и как должно быть просуммировано. Есть только два листа. Один из них суммирует данные другого. Но суммы почему-то различаются. Вы свой пример смотрели? Строки у Вас различаются, да. А столбцы нет. Зато суммы в них различаются. Ну раз есть проблема - потрудились бы хоть пример-то составить нормально, чтобы додумывать не пришлось чего надо в результате...

По идее, для суммирования нужна такая формула:
Код
=СУММПРОИЗВ((Лист2!$A$2:$A$12=$A2)*(Лист2!$B$1:$D$1=B$1)*(Лист2!$B$2:$D$12))
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
Извините, если не очень удачный пример составил, попробую раскрыть суть(
Это два разных файла, с разной номенклатурой, но одинаковыми городами. Мне нужно совместить их, путем суммирования количества по одинаковой номенклатуре и по городам. И т.к. номенклатуры много, чтобы ексель сам выбирал одинаковую номенклатуру и построчно суммировал. Т.е. как должно получиться я на третьем листе показал.
Главный у меня вопрос именно в том, чтобы ексель сам выбилал повторяющуюся номенклатуру между файлами и по ней суммировал количества по городам (построчно).
Ну и выделял цветом те позиции, которые не просуммировались.
 
Ну как-то так. Только диапазоны установите либо динамические либо B:B
 
Спасибо! Формулу перенести получилось, но постоянно выскакивает окошко "обновить сумму" и предлагает выбрать файл...
 
Не понимаю почему так может быть. Ибо не понимаю как Вы переносили
Попробуйте написать свои формулы СУММЕСЛИ.
Вам по сути нужно служить результат СУММЕСЛИ 1го листа с результатом СУММЕСЛИ 2го листа
 
Спасибо за помощь, но формулу так до конца и не получилось довести. Начал уже по другой дороге идти)
Форумчанам спасибо за оперативные ответы!!!)
Страницы: 1
Читают тему (гостей: 1)