Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Выбор диапазона в соответствии с датой, vba
 
Добрый день, уважаемые знатоки!
Помогите, пжл., с реализацией следующей задумки. (файл прилагаю).

На листе "Общий" ведется ежедневное фиксирование кол-ва продаж 2х менеджеров.
Необходимо, чтобы на листе месяц при выборе даты из выпадающего списка отображался диапазон за период с первого числа месяца по указанную дату.

За ранее премного благодарен.  
 
вариант с ГПР
фрилансер Excel, VBA - контакты в профиле
"Совершенствоваться не обязательно. Выживание — дело добровольное." Э.Деминг
 
ikki
Спасибо, но этот вариант работает только за 1 день, за конкретную дату,
а мне нужно чтобы, к примеру при выборе 21.03 - показало период за 03 месяц с 1-21 числа
Изменено: trolololy - 21 Мар 2015 12:56:15
 
Васю/Петю "довыбираете", имхо, сами... ;)
Вариант - =СУММЕСЛИМН(общий!$B$2:$BH$2;общий!$B$1:$BH$1;">="&A2;общий!$B$1:$BH$1;"<="&B2).
Даты, однако, надо брать в вилку - от/до, а точнее - с/по включительно.
Изменено: Z - 21 Мар 2015 12:09:15
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Z,
Спасибо, да работает, но опять же немного не то )
Интересно именно, чтобы он не суммировал, а делал копию диапазона с листа общий и выводил его на лист месяц в виде фрагмента за период от 1 числа месяца и до указанного.
Эта формула, что вы привели тоже пригодится, но, к примеру для консолидированного расчета за эти даты/суммы )
Изменено: trolololy - 21 Мар 2015 12:56:55
 
Цитата
trolololy написал: ... чтобы он не суммировал, а делал копию диапазона...
Не обижайтесь, но ваша "хотелка", как и ваша организация данных, имхо, совершенно далеки от электронных таблиц и xl-ской работы с ними.
Побродите по форуму, загляните в "Приемы" - они дадут вам много пищи для размышлений и САМОсовершенствования. Удачи!.. ;)
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Z,
Спасибо за совет, буду пытаться )
Просто уже видел нечто подобное реализованное по средствам макроса, когда он завязан на ячейку с выпадающим списком...возможно я не по адресу )
Изменено: trolololy - 21 Мар 2015 12:57:28
 
вариант
фрилансер Excel, VBA - контакты в профиле
"Совершенствоваться не обязательно. Выживание — дело добровольное." Э.Деминг
 
ikki,
спасибо огромное, вы мой спаситель )
думал, такое возможно только с помощью макросов.
Ушел разбираться и самосовершенствоваться ;)
Страницы: 1
Читают тему (гостей: 1)