Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
средненедельный объем продаж за выбранный диапазон дат
 
Доброе утро, уважаемые форумчане!
Несколько дней читаю форум, много полезного научился делать, но задачу свою так и не решил.

Исходные данные:
Имеется несколько артикулов товаров (SKU1, SKU2 и т.д.), по каждому артикулу есть продажи за каждую из 52 недель года.
Задача: найти средненедельные продажи за выбранный диапазон дат (недель). Например, пользователь выбирает диапазон 2 неделя и 4 неделя и формула считает средненедельные продажи за этот период.

Научился возвращать с помощью ф-ций индекс и поискпоз данные за одну любую неделю, но с диапазоном не разобрался. Пытался совместить с ф-цией срзначеслимн, но безуспешно.

Пример файла во вложении.
 
Так?
Код
=ЕСЛИОШИБКА(СРЗНАЧ(ИНДЕКС(Post_Promo[[w1]:[w52]];ПОИСКПОЗ(A15;Post_Promo[SKU];0);ПОИСКПОЗ("w"&E$2;Post_Promo[[#Заголовки];[w1]:[w52]];0)):ИНДЕКС(Post_Promo[[w1]:[w52]];ПОИСКПОЗ(A15;Post_Promo[SKU];0);ПОИСКПОЗ("w"&E$3;Post_Promo[[#Заголовки];[w1]:[w52]];0)));"")
 
Алишер, спасибо огромное!
Пошел разбираться как Вы это сделали :)
 
См. вариант - макрос - выполняется для любого количества артикулов.
Изменено: Мотя - 22 Мар 2015 10:54:12
 
Мотя, спасибо! Тоже отлично работает.

С макросами пока дело не имел. Посмотрел код, буду разбираться как работает. Захватывающая штука этот эксель :)
Страницы: 1
Читают тему (гостей: 1)