Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Обновление сводной таблицы в Excel 2010
 
Уважаемы форумчане, столкнулся с такой проблемой :

Есть файл с данными, из которых формируется сводная таблица. Соответственно, когда вносятся новые данные - информация в сводной таблице обновляется. Исходные данные и сводная находятся в одном файле.
Копирую файл.(сохранить как) Переименовываю его . Работаю дальше в нем . Вношу данные и хочу обновить сводную. Пишет, что не может этого сделать, ссылаясь на старый (до переименования) файл т.е. в источнике данных сводная ссылается на лист из старого файл. Приходится заново указывать источник данных (диапозон данных).
В экселе 2003, 2007 не было такой проблемы сводные таблицы обновлялись после переименования, пересохранения файла с другим именем.

Может кто  сталкивался с данной проблемой и знает, как в 2010 экселе сделать, чтобы сводные после переименования файла - обновлялись?
 
а если источник - "умная таблица"?..
у самого такие "фишки" возникают на 2013. не доходят руки разобраться
ПС. только что проверил на примере, если копировать весь файл (сводная и таблица-источник в одном файле), то ссылок на другой файл нет, а если только сводную, то возникает (что логично)

попробуйте не через сохранить как, а копи-паст самого файла
Изменено: googlogmob - 22 Мар 2015 10:49:02
 
Цитата
googlogmob написал: попробуйте не через сохранить как, а копи-паст самого файла
попробовал. не получилось (((  . Также обращается к старому файлу!
 
cityfox, а исходный файл при этом закрыт?
выложите Ваш файл
Изменено: googlogmob - 22 Мар 2015 13:28:41
 
Цитата
googlogmob написал: выложите Ваш файл
блин , там рабочий файл, не выложу (

я на рабочем компе сделал файл : в нем вбил два параметра - дата и цифра (напротив даты) . Сделал сводную, далее скопировал файл, далее добавил данные и нажал обновить...... в итоге сводная в копии файла обновилась.
в общем, в рабочем файле где то галочка стоит, которая не дает обновить сводную....осталось понять где!!!
 
Цитата
cityfox написал: блин , там рабочий файл, не выложу
Создайте аналог. Какие проблемы?
 
Цитата
cityfox написал: Копирую файл.(сохранить как) Переименовываю его
Попробуйте при пересохранении ("Сохранить как") сразу задавать новое имя, а не переименовывать файл потом.
Проблема известная, правда, больше на 2013.
F1 творит чудеса
 
Не знаю у меня проблем таких не возникало, единственное что было, это когда заканчиваешь месячный файл, копируешь (сам файл) вставляешь и переименовываешь, затем удаляешь старые исходные данные и... вот в этом месте и была загвоздка, поля сводной "запоминали" старые (уже удаленные данные) и при выборе фильтра для поля было много мусора из старых данных (те же даты февральские например уже в мартовском файле), побеждается этот недуг просто, параметры сводной таблицы -> вкладка "Данные" -> в графе "сохранять элементы, удаленные из источника данных" указать число элементов, сохраняемых для каждого поля вместо "авто" - "Нет". После обновления таблицы можно вернуть все обратно если параметр важен.
PS: В этой же вкладке есть галка на "Сохранять исходные данные вместе с файлом" честно говоря не совсем понимаю что это значит, может обратить на нее внимание?
 
Цитата
GeorgeDark написал: "Сохранять исходные данные вместе с файлом" честно говоря не совсем понимаю что это значит
Это значит, что кэш сводной сохраняется с ней, независимо от того, сохранен ли источник данных. Увеличивает объем файла, но позволяет хранить только сводную, изменять ее структуру и получать расшифровки из нее, особенно если исходник - в другом файле.
F1 творит чудеса
 
Цитата
Максим Зеленский написал: Попробуйте при пересохранении ("Сохранить как") сразу задавать новое имя
Всё так и сделал. Всё равно не помогает (
Файл большой. Порядка 25 листов с таблицами, диаграммами . В основном листе таблица с данными, формулами. строк порядка 20 тысяч ...
Самое интересное, что раньше такой проблемы не было! Всё сохранялось, чистилось, обновлялось!
 
то есть, это не помогло?
Код
As a workaround, I tick the option 'prefer the Excel Data Model..' to get rid of this issue.When I create a pivot table, excel create a data model and then when I copy it to another folder, it would not change my data source path. 
File->options->advanced->find the Data group, check the option 'prefer Excel Data Model....' 

For these workbooks which have already created the pivot table, you can use 'save as' to save it to another folder, I've tested it, the path wouldn't become to absolute.
 
это не пробовал. сейчас попробую.
Изменено: cityfox - 5 Май 2015 13:49:35
Страницы: 1
Читают тему (гостей: 1)