Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Один документ с данными из базы
 
Просьба помочь с решением следующей задачи.
В Листе 1 - данные (всегда разное количество строк), в Листе 2 - документ, куда надо вставить строки из Листа 1.

Но, количество строк в Листе 1 всегда разное, и не знаю как лучше всего сделать автовставку данных в Документ.
Не подскажите как лучше всего реализовать?  
 
Для начала показать файл-пример (небольшой) с исходными данными и желаемым результатом.
 
Прикладываю пример. Соответственно, если в Листе 1 строк - 50, то и в Листе 2 должно быть столько же...
 
В принципе, на лист с документом можно вставить нижеприведенную формулу и с избытком растянуть ее на максимально возможное количество строк и столбцов в исходных данных (допустим, до 100 строк и до 10 столбцов)

Код
=ЕСЛИОШИБКА(ИНДЕКС(СМЕЩ(Лист1!$A$1;0;0;СЧЁТЗ(Лист1!$A:$A);СЧЁТЗ(Лист1!$1:$1));СТРОКА(Лист2!C1);СТОЛБЕЦ(A1));"")
Изменено: Пытливый - 22 Мар 2015 21:01:23
Кому решение нужно - тот пример и рисует.
Страницы: 1
Читают тему (гостей: 1)