Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Расчет времени и тарифа в Excel 2007 с учетом переменных значений., альтернатива штатному и расширенному фильтру
 
Две задачи:
1. Файл "путевой лист (тест)":  

   Задача 1.1 - В таблице приведены запланированные, последовательные отрезки времени, на которые должен ориентироваться водитель.
В "желтой" ячейке должно отображаться итоговое затраченное время. В данном случае равно =O50-O29 (6:30), и все бы хорошо, но количество точек на маршруте
может меняться, т.е. последней может стать ячейка О56, O54, или любая другая под описанием в таблице "Время отъезда". Таким образом постоянно придется править формулу. Что в общем то не сложно...я сам не ахти, но есть с кем сравнивать...понимаете.
   Задача 1.2 удалена
Что хотелось бы получить:
После решения задачи 1.1 у нас есть автоматически вычисляемое время, которое умножается на приведенные расценки в ячейке D5, т.е. цена зависит от выбранного тарифа в поле D5. Тут я иссяк, ввиду минимальной продолжительности поездки 3 часа, т.е. если водитель на 1.5 тоннике затратил на поездку 3 и менее часов, стоимость поездки должна составить 1200 рублей. За более 3х часов по честному. Прошу дать 2 варианта, с округлением по законам математики на середине часа в большую сторону. Второй вариант без округления.
Изменено: leejay2512 - 5 Май 2015 13:44:15 (Плохо прочел правила)
 
Для желтой ячейки - как вариант =МАКС(O23;O25;O27;O29;O35;O37;O39;O41)-O22
 
В D12 нет выпадающего списка.
 
Виноват Описание изменил, D12 на D5
 
Для голубой ячейки м.б. так: =ЕСЛИ(F43>3;(ЧАС(F43)+МИНУТЫ(F43)/60);3)*(СУММПРОИЗВ((D5=наименование)*цены))
Изменено: Михаил Лебедев - 24 Мар 2015 07:57:21
 
Цитата
Михаил Лебедев написал: =ЕСЛИ(F43>3
Михаил Лебедев, этот кусок всегда будет ложью так как время в числовом формате дробное и приведет к неправильным вычислениям всегда будет 3 часа умножатся на тариф
Лень двигатель прогресса, доказано!!!
 
Для желтой массивная (ячейка должна быть не объединина)
Код
=МАКС(ЕСЛИ(M22:M41="Время отъезда";O22:O41))-МИН(ЕСЛИ(M22:M41="Время прибытия";ЕСЛИ(O22:O41<>0;O22:O41)))
Код
=ЕСЛИ(ЧАС(F43)<=3;1200;ЧАС(F43)+МИНУТЫ(F43)/60)*ВПР(D5;Лист2!$B$4:$C$8;2;0)
и для синей такой вариант
Изменено: Сергей - 24 Мар 2015 08:13:29 (очепятки)
Лень двигатель прогресса, доказано!!!
 
Цитата
Сергей написал: =ЕСЛИ(ЧАС(F43)<=3;1200;ЧАС(F43)+МИНУТЫ(F43)/60)*ВПР(D5;Лист2!$B$4:$C$8;2;0)
1200 рублей это частный вариант, он будет меняться в зависимости от типа выбранного авто
 
leejay2512, пишите новое название темы до этого помогать не буду формулу можно переделать вместо 1200 поставить другую
Лень двигатель прогресса, доказано!!!
 
для синей
Код
=ЕСЛИ(ЧАС(F43)<=3;3*ВПР(D5;Лист2!$B$4:$C$8;2;0);(ЧАС(F43)+МИНУТЫ(F43)/60)*ВПР(D5;Лист2!$B$4:$C$8;2;0))
Лень двигатель прогресса, доказано!!!
 
Цитата
Сергей написал:  этот кусок всегда будет ложью так как время в числовом формате дробное
Сергей, спасибо. Не учел, но принцип то не меняется.=ЕСЛИ((ЧАС(F43)+МИНУТЫ(F43)/60)>3;(ЧАС(F43)+МИНУТЫ(F43)/60);3)*(СУММПРОИЗВ((D5=наименование)*цены))
 
Мужики, а что со второй задачей?
 
Один вопрос одна тема вы ж правила читали, создайте новую
Лень двигатель прогресса, доказано!!!
 
Итог. Для истории
Страницы: 1
Читают тему (гостей: 1)