Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Значения в последующих ячейках равны значению в вычислиямой ячейке
 
Добрый день уважаемые формучане. Помогите плиз ответить на вопрос: как сделать так, что при вычислении значения в любой ячейке этого ряда, все последующие ячейки принимали то же значение что и значение в ячейке в которой произошло вычисление, а в предыдущих этого не происходило?
 
А вычисление как происходит?
"Все последующие ячейки" - это до конца листа, или в каком-то интервале?
Пример приложите.
 
Ряд - это строка? Столбец? В столбце более 1 млн строк, в строке также немало столбцов. Нужно, чтобы значение повторялось везде?
Скорее всего, нужно просто поставить подряд формулы ссылки на предыдущие ячейки. Правда, в таком случае будет одноразовая конструкция.
F1 творит чудеса
 
Как происходят вычисления: предполагается, что на первом листе происходит вычисление некоего значения, затем при помощи формулы ЕСЛИ, с условием <>0, это значение передается на искомый лист2. Оба листа полностью  одинаковы по структуре ячеек. На втором листе все последующие ячейки в этой строке должны принимать те же значение что и значение в ячейке в которой произошло вычисление.
Вычисления производятся в строке, в которой 160 ячеек
 
Добрый день.
В F1 ввести =Е1 и тянуть вправо.

З.Ы. Точнее, лучше тогда еще вот так:
В ячейку Е1 листа2:
Код
=ЕСЛИ(Лист1!E1<>0;Лист1!E1;D1)
и тянуть вправо
Изменено: Пытливый - 25 Мар 2015 11:37:23
Кому решение нужно - тот пример и рисует.
Страницы: 1
Читают тему (гостей: 1)