Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
сумма в пересечениях
 
Доброго дня!

Суммирую (ну пытаюсь) значения по признакам. Например, "белый" в "2013". Должно быть 14. Количество колонок постоянно меняется
2011 2012 2013 2014
белый1 5 4 4
синий 2 4 8 6
белый 5 2 10 7
желтый 8 14 5 4
=SUM(INDIRECT("Лист'!"&ADDRESS(MATCH("белый",'Лист'!$A:$A,0),MATCH("2013",'Лист'!$1:$1,0))):INDIRECT("Лист'!"&ADDRESS(MATCH("белый"'Лист'!$A:$A,0),MATCH("2013",'Лист'!$1:$1,0))))

не суммирует... находит 4 и все...

sumif "белый" в столбике А хочет еще колонку, но колонка все время меняется...

помогите, пожалуйста, кто чем может!
 
Код
=СУММЕСЛИ(A2:A5;"белый";ИНДЕКС(B2:E5;;ПОИСКПОЗ(2013;B1:E1;)))
Код
=SUMIF(A2:A5,"белый",INDEX(B2:E5,,MATCH(2013,B1:E1,)))
Изменено: Казанский - 25 Мар 2015 16:55:25
 
супер!!! спасибо большое!!!
Страницы: 1
Читают тему (гостей: 1)