Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Максимум из значений с определённым условием.
 
Здравствуйте!

Пожалуйста, помогите с решением следующей задачи: необходимо в файле-примере в столбце "D" установить значение максимума из столбца "E" по условию, что максимум отбирается только из строк, которые имеют признак "2" в столбце "B". Максимум устанавливается в строке с соответствующим значением.
 
Irasen, как понял.
В D и тянем:
Код
=ЕСЛИ(B1=2;C1;"") 
В E и тянем:
Код
=ЕСЛИ(D1="";"";МАКС($D$1:$D$25))
Изменено: Smiley - 25 Мар 2015 17:41:28
Учусь программировать :)
 
Smiley,  впринципе да, но не до конца. Необходимо что бы максимум был установлен один раз в соответствующей ему строке.
 
В D1 можно вставить такое (формула массива, вводится одновременным нажатием Ctrl+Shift+Enter):

Код
{=ЕСЛИ(МАКС(($B$1:$B$25=2)*($C$1:$C$25))=C1;МАКС(($B$1:$B$25=2)*($C$1:$C$25));"")}


и потом протянуть вниз
Кому решение нужно - тот пример и рисует.
 
Сокращенный вариант (формула массива):
Код
=ЕСЛИ($C1=МАКС(($B$1:$B$25=2)*$C$1:$C$25);$C1;"")
 
Пытливый,  работает! Огромное спасибо!!!
 
Влад,  супер!!! Спасибо!!!
Страницы: 1
Читают тему (гостей: 1)