Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Вычислить сумму по двум значениям из другого листа
 
Здравствуйте!
Просьба, помочь в данном решении
Вычислить сумму по двум значениям одно из них дата
которая может меняться , то есть значения за какой то период времени
образец прилагаю

За ранее спасибо всем откликнувшимся!!!
 
Так ?
Код
=СУММЕСЛИМН(общая!V6:V20;общая!F6:F20;"яблоки";общая!A6:A20; ">=" & итоги!D1)
 

 
нет не так
не правильно может описал...
!V6:V20    !F6:F20  ,A6:A20 не должно быть фиксировано
формула сама должна находить дату в листе "общий" и по этой дате смещение в сторону на 6 ячеек +критерий по названию
смещение впринцепи не обязательно можно дату поставить над ячейкой " сумма " везде.
 
Т.е., дата у вас может "валяться" на листе в любой колонке или я опять не так понял объяснения? Или вас смущает ограниченность диапазона 6:20? Тогда можете задать его в виде "А:А" и т.п.
 
дата может быть в любой колонке
на сколько я понимаю мы ставим зависимость, диапазон суммирования "общая!V6:V20" он не может считать в другом столбце
я пользуюсь этой формулой постоянно сам..
я не понимаю как что бы находила колонку по значению "даты" и суммировала ее по второму значению "яблокам " например... или туплю  
 
МВТ,
давайте так,
дата в листе "общая" находится над ячейкой  "сумма"

 в листе "итоги" должно искать с листа "общая "
1) по дате- диапазон   A3:AH3 (начальная дата по горизонтали) , A4:AH4 (конечная дата по горизонтали)
находит этот столбец    , может здесь я не правильно объяснил , ищем желтое выделенное поле
дальше второе значение, например "яблоки" из столбца F суммирует все
то есть должно получиться
в листе "итоги" ячейка D2 сумма 110
 
Код
=СУММ(ЕСЛИОШИБКА(ИНДЕКС(общая!$Q$6:$AH$20;Ч(ИНДЕКС(ЕСЛИ($A4=общая!$F$6:$F$20;СТРОКА($A$1:$A$15));));ПОИСКПОЗ(D$2+1;общая!$Q$3:$AH$3;0)-1);))
"..Сладку ягоду рвали вместе, горьку ягоду я одна."
 
Владимир,
по моему она не работает
ставлю ее в пример ноль показывает...
 
Иван Иванов, она массивная прекрасно работает вводится сочетанием 3-х клавиш
Лень двигатель прогресса, доказано!!!
 
Сергей,
пожалуйста скиньте в моем файле
я ставлю ее нажимаю 3 клавиши  shift ctrl tnter  дает не те суммы
да, может  я неправильно что то делаю

в примере реально будет увидить
 
Я не могу понять почему в первом столбце считает не верно. Если смотреть через F9, то всё правильно. И тем не менее СУММ выдаёт неправильный результат.
???
"..Сладку ягоду рвали вместе, горьку ягоду я одна."
 
Если ставить СУММ, считает неверно, потому что нельзя при использовании ИНДЕКС применять для выборки нулевые значения строк - в таком случае функция возвращает ВЕСЬ столбец (при расчетах - первое значение), что и получается в формуле.
Вот такой вариант в данном случае сработает.
Изменено: Влад - 26 Мар 2015 12:33:48
 
Вариант с суммпроизв со смещением диапазона
Лень двигатель прогресса, доказано!!!
 
Цитата
Сергей написал: Вариант с суммпроизв со смещением диапазона
- отличный вариант)
 
Влад, по чему то не считает 3 столбец период  с 01.03.2015 по 31.03.15

какой либо разницы в формуле я не вижу...
 
Я логику формулы не анализировал, посмотрел только проблему подсчета.
PS. Причина: неполностью заданы диапазоны расчета + в AI для работы формулы Владимира должны быть следующие даты апреля.
Изменено: Влад - 26 Мар 2015 12:55:09 (посмотрел причину)
 
Цитата
Влад написал: (при расчетах - первое значение),
Нет, у меня эта теория не подтвердилась.
Заметил, что если первая строка (строка 6 в "итогах") имеет нулевые значения, то расчёт идёт правильно, а если нет..
То нужно увеличить диапазон на 1 строку, т.е. вместо  - общая!$Q$6:$AH$20, "общая!$Q$5:$AH$20" и соответственно "общая!$F$5:$F$20".
"..Сладку ягоду рвали вместе, горьку ягоду я одна."
 
Сергей, Спасибо!
все хорошо работает
Страницы: 1
Читают тему (гостей: 1)