Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Поиск ячейки содержащей текст из другой ячейки
 
Подскажите пожалуйста. Мне нужно найти текст из ячейки в диапазоне и посчитать по двум условиям (=суммеслимн)

Сейчас у меня так =СУММЕСЛИМН(Продажи!C:C;Продажи!B:B;"текст*" ), но мне нужно, чтобы условие обращалось в ячейку содержащую текст. (в замену "текст*" , условие нужно брать из ячейки, так как условий для поиска очень много.

Сильно не судите;)
Изменено: Begert - 25 Мар 2015 21:16:07
 
ну и?
Код
=СУММЕСЛИМН(Продажи!C:C;Продажи!B:B;A1)
неужели проще написать на форум, нежели попробовать вместо текста подставить адрес ячейки?
Изменено: Dima S - 25 Мар 2015 21:53:39
 
Так мне не нужно. Это и дураку понятно. Мне нужно искать текст содержащийся в диапазоне и в ЯЧЕЙКЕ!!! и если этот тест находится, то считать по условию. В данном случае он будет искать в точь такое условие и ничего не найдет
 
Так "на пальцах" будете долго пояснять, что Вам нужно. Неужели нельзя показать небольшой файл-пример?
 
условиядиапазонУсловияэто мне нужно посчитать
текст в тексте1текст0
это не нужно2не нужно0
это тоже не нужно3400
текст нужен этот4200
текст 345340
теск 406
не нужно 207
не нужно 408
Изменено: Begert - 25 Мар 2015 23:07:47 (прикрепил фаил)
 
Для Е2
Код
=СУММЕСЛИМН(B:B;A:A;"*"&D2&"*")
 
Замечательно, это то, что нужно. Огромное спасибо!)))
 
Ребят, а как в данном случае поступить?
 
Код
=СУММПРОИЗВ(($A$2:$A$8&"/"&$B$2:$B$8=E2)*$C$2:$C$8)
фрилансер Excel, VBA - контакты в профиле
"Совершенствоваться не обязательно. Выживание — дело добровольное." Э.Деминг
 
Спасибо огромное
Страницы: 1
Читают тему (гостей: 1)