Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Выдавать в ячейку значение при выполнение условий
 
Добрый день,
Помогите пож. формулой в экселе я пока, что не очень:
Если в ячейке A2 или B2 или и там и там встречается значение "да", написать в ячейке C2 "кратно", иначе "не кратно"
 
Добрый день.

Код
=ЕСЛИ(ИЛИ(A2=B2="да";A2="да";B2="да");"кратно";"не кратно")
Изменено: Пытливый - 26 Мар 2015 13:10:41
Кому решение нужно - тот пример и рисует.
 
=ЕСЛИ(ИЛИ(A2=B2;A2="да";B2="да");"кратно";"не кратно")

A2=B2 ??? где это в условии... при обоих пустых выдаст также "кратно"
Изменено: modest - 26 Мар 2015 13:17:13
 
Код
=IF((A2="да")+(B2="да"),"кратно","не кратно")
 
Добрый день,
Что не так в В2 есть значение да - должно в С3 быть кратно
 
а можно для общего развития? эта формула в эксель?
Изменено: modest - 26 Мар 2015 14:39:33
 
как то так
 
Спасибо работает
=ЕСЛИ(ИЛИ(A2=B2=  "да";A2=  "да";B2=  "да"  );  "кратно";  "не кратно"  )
Вопрос по Н/д если в таблице встречаются такие результат Н/д пример.
а2 да в2 н/д результат н/д, а хочется "кратно"
 
Для общего развития - Эксель бывает не только русским...
И люди живут не только в Росии :)
Изменено: Hugo - 26 Мар 2015 13:26:50
 
Gennadiy1234, Еслиошибка(формула;"кратно")
Лень двигатель прогресса, доказано!!!
 
Цитата
Hugo написал: Эксель бывает не только русским...
Это понятно... Но через запятую... и + в условии...  
 
Цитата
Hugo написал: Эксель бывает не только русским
там другие разделители и чем вас смутил плюс?
Лень двигатель прогресса, доказано!!!
 
спасибо!!!!
 
да всё смутило (арифметический + и логическое сложение), но приму к сведению... А такой вопрос - ведь эти формулы в русском экселе тупо не работают?
Изменено: modest - 26 Мар 2015 14:41:57
 
тупо не работают потому что они для английской локализации замените запятую на точку с запятой и IF на Если они начнут тупо работать
Лень двигатель прогресса, доказано!!!
 
Цитата
modest написал: эти формулы в русском экселе тупо не работают?
Да, если брать из этого форума - нужно переводить под себя, и под свои разделители. Если бы я мог выслать в файле - работали бы, даже не смотря на разделители.
В другом форуме есть опция перевода.
Надеюсь Виктор не осерчает - вроде как чесать разрешил... :)
Изменено: Hugo - 26 Мар 2015 14:42:51
 
все понял. ну их к бесу эти цитаты! Хорошо хоть человек успел файл скачать и проблема решена. Вторая моя ветка на этом форуме, но данный модератор меня... "уж очень сильно опекает" по-русски говоря...
 
modest, всего-лишь - следовать правилам. Это не тяжело. пять минут на прочтение.
И никто Вас доставать не будет.
В Вашем доме свои порядки, здесь - свои. прошу соблюдать, не более.

Сообщение №6 - цитату удалили. Непонятно, о чем речь.
Смысл - цитировать то, что нужно, и если нужно.
Страницы: 1
Читают тему (гостей: 1)