Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Формула расчета рейтинга
 
Добрый день! Как в Excel можно реализовать следующее:
Есть таблица рейтинга нескольких участников конкурса. Рейтинг отдельного участника рассчитывается по формуле A(min)/A(i)*100.  
A(min) - наименьшее предложение о цене (из всех участников).
A(i) - предложение i-го участника.
Нужно рассчитать рейтинг отдельно взятого участника, но при этом, если его предложение, или предложение любого другого из участников, ниже установленного лимита, то оно должно считаться равным этому лимиту.
Всем заранее спасибо за ответ!
Изменено: alerta - 26 Мар 2015 13:21:51
 
alerta, найдется мало помогающих которые захотят делать за вас пример в файле что есть как хотелось бы
Лень двигатель прогресса, доказано!!!
 
Да, Сергей, вы правы. Вот табличка. В ней есть формулы расчета, но они не включают ограничение по лимиту цены предложения. Не могу придумать, как это сделать...
 
Код
=ЕСЛИ(C7=0;0;МИН($C7;$E7;$G7;$I7;$K7;$M7;$O7)/Если(C7<ЯЧЕЙКА С ЛИМИТОМ;ЯЧЕЙКА С ЛИМИТОМ;С7)*100)
Кому решение нужно - тот пример и рисует.
 
Пытливый, да я так же хотела. Но тут загвоздка в том, что не учитываются предложения других участников. Формула увидит их "как есть", а ведь они тоже могут быть ниже лимита.
 
alerta,я так понимаю Вам нужно не формулу менять а задавать ячейке (где ставятся параметры участников) ограничение если сумма меньше или больше  установленного лимита запрет на ввод или дублировать таблицу хоть на другом листе где будут при нарушении условия подставляться данные лимитов и уже оттуда подтягивать рейтинг
Лень двигатель прогресса, доказано!!!
 
Цитата
alerta написал:
Но тут загвоздка в том, что не учитываются предложения других участников.
есть три заявки: 80, 90, 101
Если лимит = 100, то тогда какой рейтинг у первого участника? 100/80? 100/100? 80/100?
То есть, при подсчете минимума предложений заявки участников должны сводиться к лимиту?
тогда, по примеру формулы Пытливого, расчет рейтинга участника 1:
Код
=МАКС(ЛИМИТ;МИН($C$7;$E$7;$G$7;$I$7;$K$7;$M$7;$O$7))/МАКС(C7;ЛИМИТ)

Первая часть формулы: берет минимальное значение предложений, если оно выше лимита, или лимит, если оно ниже.
т.е., если среди всех предложений встречаются предложения ниже лимита, в качестве A(min) будет взят лимит (если не так - то поясните,как)
Вторая часть: берет предложение участника 1, если оно выше лимита, или лимит, если оно ниже.

Все работает правильно?
Изменено: Максим Зеленский - 26 Мар 2015 15:53:05
F1 творит чудеса
Страницы: 1
Читают тему (гостей: 1)