Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Процент выполнения плана с отрицательными и положительными значениями
 
Всем привет!
Помогите пожалуйста, ломаю голову целый день....
первое задание посчитать процент с отрицательным значением в плане
например: план "-100"  факт 200, с этим справилась такой формулой (B2-A2)/A2*-1  , где А2 это план, в итоге получаем искомые 300% выполнения.
Загвоздка в том что если в эту формулу подставить положительные значения, она будет не верна.
Помогите пожалуйста




 
 
Отбой)) справилась))
ЕСЛИ(A2<0;(B2-A2)/A2*-1;ЕСЛИ(A2>0;B2/A2))
 
А2=0? Если такое есть, нужно добавить
=ЕСЛИ(A2<0;-(B2-A2)/A2;ЕСЛИ(A2>0;B2/A2;0))
Если нет, то проверка второго условия лишняя. С упрощениями:
=ЕСЛИ(A2<0;A2-B2;B2))/A2
 
Спасибо большое!!!
 
Рано радовалась, необходимо учесть 0, оба отрицательных значения и оба нулевых  значения.
Сейчас формула выглядит так :=ЕСЛИ(A2<0;(B2-A2)/B2;ЕСЛИ(A2>0;B2/A2;ЕСЛИ(A2=0;B2)))
Еще не понимаю почему тут неправильно считает, явно процент будет больше.
К сожалению не могу найти как прикрепить файл((
-      1 103 116.00       1 443 351.00   176%
План Факт % выполнения
-         181 255.00          152 879.00   219%
               6 704.00               7 738.00   115%
            17 455.00             70 883.00   406%
                           -                              -     0%
          497 726.00          640 891.00   129%
       2 781 964.00       8 690 933.00   312%
-            91 545.00          546 808.00   117%
          559 223.00             31 004.00   6%
-      1 686 740.00          280 515.00   701%
-         760 847.00          284 071.00   368%
-      1 103 116.00       1 443 351.00   176%
-         587 903.00   -       204 953.00   -187%
          242 827.00       1 652 341.00   680%
          377 697.00   -       121 000.00   -32%
                           -                  
 200.00  
20000%
Изменено: Tzolton - 27 Мар 2015 16:23:31
 
Цитата
Tzolton написал: К сожалению не могу найти как прикрепить файл((
четыре строчки выше кнопки "Ответить"
 
Спасибо) прикрепила, выше
 
"% выполнения" лучше, по-моему, переименовать в "отклонение в %", да и отрицательные значения в "плане" и "факте" как-то необычно выглядят
=ЕСЛИ(A2=0;1;ЕСЛИ(И(A2<0;B2<0);B2/A2;ЕСЛИ(A2<0;B2/ABS(A2)+1;ЕСЛИ(B2<0;B2/A2-1;B2/A2))))
Изменено: vector1 - 29 Мар 2015 18:40:12
EliteBook 8570w, i7, 24Gb Ram
OfficeProPlus 365x64
 
Спасибо большое за формулу, только она до конца не верна.
в файле отметила желтым где считает не правильно.
Отрицательные значения в плане и факте это нормально)) если речь идет не о штуках, а о деньгах, например.
 
базовый столбец - план
поэтому все, что выделено желтой заливкой является корректным
EliteBook 8570w, i7, 24Gb Ram
OfficeProPlus 365x64
 
Если считать математически ( на калькуляторе :) ) то выделенное желтым считается не правильно
 
Не знаю что и как неправильно, написал свои формулы (не подглядывая в ранее написанные) и у меня получилось вот что (зеленым покрасил расхождения со столбцом D). Если что-то неправильно считается напишите по какому алгоритму вы считаете на калькуляторе, проверю, поясню )
 
Tzolton, если на кнопке написано "цитировать", это не значит, что нужно жать ее для ответа!
 
Решила наконец задачу)) вдруг кому пригодится. Зеленый столбец рассчитывает  при различных вариантах верно
Страницы: 1
Читают тему (гостей: 1)