Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
СУММЕСЛИ суммирует только верхнюю строку в диапазоне, Задача: суммировать данные в диапазоне, охватывающем несколько строк и столбцов
 
Задача: суммировать данные в диапазоне, охватывающем несколько строк и столбцов, по условию в первой строке. По сути, СУММЕСЛИ должен считать верно, но суммирует только верхнюю строку :( Как можно вылечить или может есть другой способ???
Я еще ооочень далеко не волшебник, я только учусь...
 
суммесли работает с одинаковыми диапазонами условия и суммирования глядите в сторону другой формулы Суммпроизв, массивную сумм либо используйте доп строку с суммой колонки
Лень двигатель прогресса, доказано!!!
 
У меня так получилось, попробуйте
Код
=СУММПРОИЗВ(($B$1:$G$1=I2)*($B$2:$G$6))

 
Спасибо! Смотрела на нее, но к вечеру, видимо, мозг отказывался воспринимать )))
Я еще ооочень далеко не волшебник, я только учусь...
 
так показать из за чего не работало и как будет работать СУММЕСЛИ(
Лень двигатель прогресса, доказано!!!
 
Была уверена, что эта логика работает с СУММЕСЛИМН. Куда бы не ткнулась, везде говорят, что СУММЕСЛИ работает на диапазонах разного размера, вот и застряла. СУММПРОИЗВ не пользовалась, как-то не пригождалось раньше...
Еще раз спасибо :)
Я еще ооочень далеко не волшебник, я только учусь...
Страницы: 1
Читают тему (гостей: 1)