Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Ссылка на поле таблицы
 
Здравствуйте, подкажите как в формуле: Вместо База[1] прописать ссылку на ячейку, где записан номер столбца: А6, Пример: "База[" & A6 & "]"
Код
=СУММЕСЛИМН(База[9];База[2];$C$1;База[1];D$4)

 
чет вы какие то сложности придумываете у вас ссылки на умную таблицу вроде как, База[1] = ссылке на таблицу типа А6:А999, пример бы приложили че не получается
Лень двигатель прогресса, доказано!!!
 
Немножко изменила адрес ячейки и есть связи не обновлять
 
дак там у вас ваще ссылки на другую книгу
Лень двигатель прогресса, доказано!!!
 
Извените, я все неправильно сделела
ССылка просто в примере, не могу же я выставить базу с зарплатой организации
Вложение неправильное
Мне что необходимо:
=СУММЕСЛИМН("База[" & B5 &"]";База[2];$C$1;База[1];D$4)

Вместо этого фрагмента: "База[" & B5 &"]", это суммируемый диапазон
В ячейке B5 есть номер нужного столбца, в котором нужно провести суммирование.
Извините, за предыдущие сообщения
 
Цитата
Татьяна Андреева написал: не могу же я выставить базу с зарплатой
да этого и не нужно, нужен пример с подобной структурой, небольшой, до 100 Кб, а то эти непонятки еще долго будут продолжаться
Согласие есть продукт при полном непротивлении сторон.
 
Татьяна Андреева, нам ваша зарплата не нужна, если ссылаетесь на другую книгу сделайте два листа в примере но сделайте в реальной структуре с левыми данными  
Лень двигатель прогресса, доказано!!!
 
Пример
 
Код
=СУММЕСЛИМН(ДВССЫЛ("База["&$B5&"]");База[Табельный номер];$C$1;База[Месяц];D$4)
F1 творит чудеса
 
В ячейке B5 вовсе не НОМЕР столбца, а ЗАГОЛОВОК. Что должно получиться в результате работы формулы? Сумма столбца "9" из Лист1?
Изменено: Sanja - 27 Мар 2015 10:56:40
Согласие есть продукт при полном непротивлении сторон.
 
вариант
Лень двигатель прогресса, доказано!!!
 
Максим Зеленский, спасибо, все работает[/QUOTE]
Страницы: 1
Читают тему (гостей: 1)