Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Подсчет данных до определенного месяца
 
=СЧЁТЕСЛИМН('Травмы 2014'!$C:$C;$E$1;'Травмы 2014'!$G:$G;Лист2!C162;'Травмы 2014'!D:D;"<=февраль") Помогите не выполняет последнее условие.
 
без примера данных ответить нереально. можно лишь предполагать.
фрилансер Excel, VBA - контакты в профиле
"Совершенствоваться не обязательно. Выживание — дело добровольное." Э.Деминг
 
вот пример
 
В столбце не месяц, там - текст, "февраль"<"январь"
Пишите дату, можно с форматом ячейки, отображающим название месяца, но обязательно числом.
 
Вот так?
 
там ещё вдобавок и типы значений разные... в столбце A и диапазоне G1:L1...

с учетом этого, по первому файлу, формула для G2
Код
=СУММПРОИЗВ((ПОИСК(ПСТР($E$2;2;2);"нвеварпрайюнюлвгенктояек")>=ПОИСК(ПСТР($B$1:$B$18;2;2);"нвеварпрайюнюлвгенктояек"))*($A$1:$A$18=""&G$1)*($C$1:$C$18=$F2))
Изменено: ikki - 29 Мар 2015 23:30:13
фрилансер Excel, VBA - контакты в профиле
"Совершенствоваться не обязательно. Выживание — дело добровольное." Э.Деминг
 
Вот это что? "нвеварпрайюнюлвгенктояек"
 
Для Вашего примера можно и так.
 
Большое спасибо!!!!!!!! То что нужно!!!!!!!!!
Страницы: 1
Читают тему (гостей: 1)