Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Смещение значений через два столбца
 
Здравствуйте.
Нужна формула.
Пример:
На листе1 в 1 строчке и в каждом столбце проставлены разные даты, нужно перенести эти же даты на лист2 так же в1 строчку, но через каждые два столбца.
Пробовал =СМЕЩ(Лист1!$A$1;;(СТОЛБЕЦ()/2)-2), но что-то не то, в начале вроде вставляются нужные даты, но потом съезжают.

Заранее благодарю.
 
Код
=ИНДЕКС(Лист2!$A$1:$AS$1;СТОЛБЕЦ()*3-2)

упс не так условие понял. :)
Изменено: V - 30 Мар 2015 14:43:11
 
Почему то вставился только первый день а дальше нет
 
Вроде так:
Код
=СМЕЩ(Лист1!$A$1;0;((СТОЛБЕЦ(A1)+2)/3)-1)
 
Аллилуя, спасибо вам добрый человек!
 
Предлагаю так или воспользовавшись частью формулы из поста № 4 применить такую формулу.
Код
=IFERROR(INDEX(Лист1!$A$1:$AS$1;((COLUMN(A1)+2)/3));"")
;)
Изменено: jakim - 30 Мар 2015 16:10:20 (дополнение)
 
Вот еще один вариант подсказали:

=ЕСЛИ(ОСТАТ(СТОЛБЕЦ()-1;3);"";ИНДЕКС(Лист1!$A$1:$U$1;ОТБР((СТОЛБЕЦ()-1)/3+1)))
 
Макросом
Код
Sub DD()
For I = 1 To Cells(1, Columns.Count).End(xlToLeft).Column
    Cells(1, I).Copy Worksheets("Лист2").Cells(1, I + 2 * I)
Next I
End Sub



Изменено: МВТ - 31 Мар 2015 08:48:53
 
Spaha проверка ОСТАТ(СТОЛБЕЦ()-1;3) не обязательна если для растягивания выделять 3 ячейки.
Страницы: 1
Читают тему (гостей: 1)