Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Как посчитать все проданные яблоки?
 
Здравствуйте! Есть таблица, где столбец А - наименование, В - количество, С - цена, В - статус (продано, отказ и т.д.).
НаименованиеКол-во Цена Статус
Яблоки 1 10 Отказ
Груши 2 15 Продано
Яблоки 3 10 Продано
Как посчитать все проданные яблоки? Т.е. если в столбце "Статус" написано - "Продано", то надо кол-во яблок умножить на цену и посчитать общее вол-во проданных яблок по всей таблице, ну и соответственно на какую сумму продали яблок.

Очень надеюсь на вашу помощь
 
В С6 формулу массива (завершать ввод Ctrl+Shift+Enter):
Код
{=СУММ((A2:A4=$A$2)*(D2:D4=$D$3)*B2:B4)}

В С7 формулу массива:
Код
{=СУММ(B2:B4*C2:C4*(A2:A4=$A$2)*(D2:D4=$D$3))}
Кому решение нужно - тот пример и рисует.
 
Пытливый, огромное спасибо, все работает :)
 
Код
=SUMPRODUCT(($A$2:$A$4="Яблоки ")*($D$2:$D$4="Продано")*B2:B4*C2:C4)
Страницы: 1
Читают тему (гостей: 1)