Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Использование СТРОКА в СМЕЩ для СУММПРОИЗВ в аналоге СУММЕСЛИМН, выдает #ЗНАЧ, EXCEL 2003
 
Добрый день. Пришел к вам из вот этой темы http://planetaexcel.ru/forum/?PAGE_NAME=read&FID=8&TID=5315 с небольшой проблемой. Попробовал воспользоваться аналогом СУММЕСЛИМН для EXCEL 2003 с динамическим изменением диапазонов через СМЕЩ, но использование формулы СТРОКА для СМЕЩ ломает все вычисления, выдавая #ЗНАЧ. При этом, если это же значение формулы СТРОКА рассчитывать в соседней ячейке, а в СМЕЩ подставлять эту ячейку, проблема исчезает. Но очень не хочется использовать еще одну колонку с формулами для первой в качестве "подпорки". Наверняка я чего-то не знаю и можно сделать одну нормальную формулу вместо двух? Подскажите пожалуйста, каким способом этого можно было бы добиться.

В качестве упрощенной иллюстрации прикрепляю пример. Вариант№2_1 и Вариант№2_2 в нём различаются только описанным выше образом, при этом один выдаёт ошибку, а другой, разнесенный на две ячейки - не выдает.
Изменено: rkrk - 2 Апр 2015 22:29:41
 
Аналогичная же проблема появляется при попытке заменить СМЕЩ на ДВССЫЛ.
 
А если без СМЕЩ()?
Код
=СУММПРОИЗВ((B3:E3="один")*(B4:E4="два")*B2:E2)
 
Без СМЕЩ нельзя, поскольку в рабочем варианте требуется использование именно динамического диапазона относительно ячейки (чтобы формулу можно было растягивать)
Изменено: rkrk - 2 Апр 2015 18:04:06
 
Попробуйте так
Код
=СУММПРОИЗВ((B3:E3="один")*(B4:E4="два")*СМЕЩ(B2;0;0;СУММ(СТРОКА(A8))-7;4))
 
Спасибо, помогло!
Страницы: 1
Читают тему (гостей: 1)