Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Проверка совпадений с помощью условного форматирования
 
Есть 2 таблицы (старая и новая версия)
Часть данных совпадает, часть - нет. Надо пометить это цветом.
Проверку наличия думаю можно сделать при помощи ПОИСКПОЗ - если найдено, то все ок, метить зеленым, если #н/д, тогда пометить желтым и так по всей таблице пройтись.

Пробовал написать что-то типа ="еслиошибка(ПОИСКПОЗ($C4;$A$4:$A$7;0);)=0"
но не работает..
как подобную формулу вставить в условное форматирование?
Изменено: Alex4 - 3 Апр 2015 11:41:09
 
А если через...УФ - Правила выделения ячеек - Повторяющиеся значения... - Уникальные ?
Согласие есть продукт при полном непротивлении сторон.
 
Таблицы расположены на разных страницах, а Повторяющиеся значения как понимаю работают только в пределах 1 листа

кроме того выделить цветом надо только, то что во второй таблице, т.е. что было удалено.
а то что добавлено можно не отмечать.
Изменено: Alex4 - 3 Апр 2015 11:46:33
 
Цитата
Alex4 написал: Таблицы расположены на разных страницах
вот для этого нужно прикладывать пример в РЕАЛЬНОЙ структуре!
Согласие есть продукт при полном непротивлении сторон.
 
Удалось решить задачу следующим образом,
Код
=ЕСЛИОШИБКА(ПОИСКПОЗ($C4;$A$4:$A$7;0);0)=0
а не не удалось, пишут, что на разных листах нельзя..

Но ниже подсказали, вроде работает, сейчас перенесу на реальную таблицу.
Благодарю Сергея :)
Изменено: Alex4 - 3 Апр 2015 12:26:55
 
Вариант создаем именованный диапазон первой таблицы и проверяем на втором листе
Лень двигатель прогресса, доказано!!!
 
прикольно на желтый УФ делал такую формулу а в файле ща другая
Код
=ЕОШИБКА(ПОИСКПОЗ(A3;эталон;0))
Лень двигатель прогресса, доказано!!!
 
Вариант с допстолбцом и уже его в условие УФ
Код
=СЧЁТЕСЛИ(C2:C100;A4)>0



 
Не могу понять в чем дело, но выделяется не правильно.
Вот кусок в котором по идее все что с ошибкой должно метиться желтым, однако там где нет ошибки, все равно выделяется.
В чем может быть дело?
Изменено: Alex4 - 3 Апр 2015 15:22:45
 
Условное форматирование определяет ошибку само:
=ПОИСКПОЗ($C4;$A$4:$A$7;0)
Почему у Вас два фармата с одинаковрй формулой?
 
прошу прощения, не тот файл выложил.
Вот обрезанный реальный
 
Первое - не допускайте появления ошибки. В формулах можно обойти с помощью проверок.
Второе - УФ заано для столбца, т.е. его диапазон начинается с А1. А Вы в формуле первой ячейкой указали ячейку третьей строки.
 
А как тогда будет правильно?
попробовал =ЕОШИБКА($B3:$B452)  и =ЕОШИБКА($B:$B)
но тоже не помогло...
 
Цитата
Вы в формуле первой ячейкой указали ячейку третьей строки.
=ЕОШИБКА(на какую строку ссылка?)
Страницы: 1
Читают тему (гостей: 1)