Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Замена слова в ВПР
 
Добрый день!
Имеется ряд значений:
001 Объект 001
002 Объект 002
003 Объект 003

Требуется в формуле ВПР
найти значения
001
002
003
Как правильно прописать формулу, чтобы
Ячейка искала значение 001 и понимала, что под этим значением должно быть 001 Объект 001?
 
Цитата
ALL__ написал: ... как правильно
off
Обычно - по Правилам:
"2.2. Опишите максимально подробно вашу задачу и желаемый результат. Желательно уточнить вашу версию Excel.
2.3. Приложите файл(ы) с примером (общим весом не более 100 Кб) в реальной структуре и форматах данных того, что есть сейчас и того, что хотелось бы на выходе. "
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Правильно писать ее в файле.
=ВПР("001*")...
 
Приношу извинения за некорректный вопрос.
Исправляюсь (данные в файле)
 
вот если будет не только три символа подключайте поиск пробела
Код
=ВПР(ЛЕВСИМВ(B19;3);$B$6:$C$14;2;0)
Лень двигатель прогресса, доказано!!!
 
Формулу "протянуть" сумеете?
Неизлечимых болезней нет, есть неизлечимые люди.
 
Вариант
Код
=ВПР(ПСТР(B19;1;3);$B$6:$C$14;2;0)
Изменено: Z - 3 Апр 2015 14:59:00
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Спасибо большое за ответы
 
Посмотрите пжста, в чем ошибка
 
Цитата
ALL__ написал:  в чем ошибка
В таблице где происходит поиск данных (A26:B39)  у вас числа сохранены как текст

Вот пробуйте:
Код
=ВПР(--ПРАВСИМВ(A7;3);$A$26:$B$39;2;0)
Изменено: AntyCapral - 4 Апр 2015 11:25:02
 
AntyCapral все получилось, спасибо большое
Страницы: 1
Читают тему (гостей: 1)