Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
В случае совпадения ячейки из Листа2 с таким-же значением в Лист1, перенос нескольких ячеек из той-же строки.
 
Доброго времени суток!
Надеюсь подскажете решение задачки.

Есть Лист1. В нем есть данные столбец "А1", расположенные в перемешанном порядке. На "Лист2" находим совпадения с столбце "А2" (то-же в перемешанном порядке).
Задача: при нахождении совпадения значений в столбцах А1 и А2, из "Лист2" скопировать часть данных в "Лист1", не одно, а несколько (я для примера сделал 3). И подставить их в определенные ячейки на "Лист1".

В столбцах "А1" и "А2" только по одному 100% совпадению (оно либо есть, либо его нет) и если есть, нужно копировать несколько ячеек.

Похожая задача уже озвучивалась на форуме, но там была необходимость перенести только одно значение, которое находится рядом с найденным (тема называлась "Перенос значения ячейки из Листа2 в Лист1 в случае совпадения соседней ячейки".
 
ВПР
 
В ячейку С3 лист1 можно вбить следующее:
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист2!$A$2:$D$10;ПОИСКПОЗ($A2;Лист2!$A$2:$A$10;0);СТОЛБЕЦ(B2));"")

Потом растянуть формулу вправо до столбца Е, затем тянуть вниз. А можно наоборот, сначала вниз, потом вправо.
Кому решение нужно - тот пример и рисует.
 
А ларчик просто открывался. 8-0
Плохо когда не знаешь, да еще и забудешь... :oops:

Огромное спасибо за наводку в нужном направлении. :D
Страницы: 1
Читают тему (гостей: 1)