Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Заменить формулу (аналог) =СЧЁТЗ на любую формулу для подсчета количества значений в закрытой книге, Версия Excel: 2003
 
Добрий вечер. Помогите пожалуйста с формулой для работы с подсчетом количества значений в закрытой книге.
Сейчас использую формулу:
=СЧЁТЗ([ФВА.xls]Файл!$A:$A)
Подсчет осуществляется, если файл ФВА.xls открыт. Нужна формула, осуществляет подсчет, когда файл закрыт. Заранее очень Вам благодарен.
 
Вроде,суммпроизв() работает
 
Есть.
=СУММПРОИЗВ(--([ФВА.xls]Файл!$A:$A>0))
Спасибо огромное за подсказку.
 
Использовал формулы аналоги для работы с закрытыми книгами:
Код
=СУММПРОИЗВ(--('C:\Documents and Settings\User\Рабочий стол\[ФВА.xls]Файл'!$A$1:$A$65536>0))
Код
=СУММПРОИЗВ(1*('C:\Documents and Settings\User\Рабочий стол\[ФВА.xls]Файл'!$A$1:$A$65536>0))
Код
=СУММПРОИЗВ(0+('C:\Documents and Settings\User\Рабочий стол\[ФВА.xls]Файл'!$A$1:$A$65536>0))
 Когда книга исходник закрыта (ФВА.xls)   -данные формулы не работают (работают - но вычисляют только в случае открытия второго файла).
Помогите пожалуйста.
Страницы: 1
Читают тему (гостей: 1)