Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Excel 2010: ВПР: допустимое количество символов в искомом значении, не срабатывает при >255
 
Всем привет.
Впервые столкнулась с тем, что формула ВПР не работает, если в ячейке, на которую в формуле ссылается поле Искомое значение, более 255 символов.
Есть ли обходной путь? Может в насктройках нужно что-то поменять?
 
Все же нашла ответ. Оказывается, ВПР не умеет искать значения, длина строки которых содержит более 255 символов.
 
Разделите на две (и более) ячейки содержимое.
Кажется все забыли про сводные :)
 
Код
=ИНДЕКС(B4:B5;ПОИСКПОЗ(ИСТИНА;ИНДЕКС(A4:A5=A2;0);0))
F1 творит чудеса
 
=ИНДЕКС($A$2:$C$4;СУММПРОИЗВ(ПОИСКПОЗ(ИСТИНА;$A$2:$A$4=$A2;0));2)

без ввода как формула массива.
Подробнее описывал здесь: Как найти значение в другой таблице или сила ВПР
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
Да, спасибо. Именно там я и нашла информацию об ограничении в 255 символов:)
Изменено: Любовь Шахтарина - 7 Апр 2015 15:20:42
 
Так ведь там же и решение приведено :-)
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
Страницы: 1
Читают тему (гостей: 1)