Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Функция ВПР для расчета товаров участвующих в акции
 
Добрый вечер! Сломал всю голову, не могу понять условие задания.
"С помощью функции ВПР рассчитать, какие артикулы, участвующие в акциях июля и августа, будут появляться в сентябрьской акции. (ориентир: ответом должен получиться старый артикул WW)"

Каким образом по артикулу можно определить будет он участвовать в акции или нет?
Уже и поиск по похожим артикулам провел - идентичных не найдено.
WW - это я так понял "Артикул WestWing"
Подскажите, пожалуйста!

Прикрепил таблицу
Изменено: viruslp - 7 Апр 2015 20:28:52
 
Похоже, что ВПР() надо использовать 2 раза по столбцам июля и августа, результат сложить оператором И()
Неизлечимых болезней нет, есть неизлечимые люди.
 
А как это все реализовать не подскажите ? С оператором не знаком
 
Доп. столбцы с "чистыми" артикулами.
=ЛЕВСИМВ(значение;9)
 
Это прекрасно, но я не настолько знаю Excel, к сожалению не понял что Вы имели в виду((
Изменено: viruslp - 7 Апр 2015 20:48:46
 
viruslp, кнопка цитирования не для ответа.

Я Вам показал, как можно отделить артикул от количества. В доп. столбец формулу, для каждого месяца свой доп. столбец.
Читайте справку по функци ЛЕВСИМВ. Учитесь, не все же готовое Вам подать.
 
vikttur, так отделить то не проблема. Как решить главную задачу так и не понял..
 
=ЕСЛИ(СЧЕТЕСЛИ_ артикула в диапазоне прошлого месяца...
 
В задании сказано  "... с помощью ВПР() ..."
Неизлечимых болезней нет, есть неизлечимые люди.
 
vikttur, Я так полагаю идентичных артикулов нет
Сделал вот такую формулу

Код
=СЧЁТЕСЛИ($B$3:$F$255;"=B3")

Не могу понять как сделать чтобы В3 съезжало вниз при растягивании  ?  
Изменено: viruslp - 7 Апр 2015 21:31:52
 
вместо "=B3" вставьте B3
Неизлечимых болезней нет, есть неизлечимые люди.
 
TheBestOfTheBest, Верно. Проверил - повторов нет. Что делать, ума не приложу.
 
Ищите, должны быть!
Неизлечимых болезней нет, есть неизлечимые люди.
 
TheBestOfTheBest,  Видимо что-то с моей формулой не то. Нашел в ручном поиске 3 повтора (D207-D209). А формула не показывает.
Только вопрос остается. как это сделать через ВПР ?)
Изменено: viruslp - 7 Апр 2015 21:43:13
 
=ЕЧИСЛО(ВПР(что_ищем;где_ищем;1;0))+ЕЧИСЛО(для второго диапазона)
 
vikttur,
Хм... Вроде что-то получилось. Спасибо!
Отпишусь завтра
 
Скинь что у тебя получилось
Интересная задача
 
Xorek3, Пожалуйста.
 
Xorek3, на форуме с незнакомыми принято общаться на "Вы"

А артикулы-то и не нужно расцеплять (отделять правую часть), они одинаковые!
=ЕЧИСЛО(ВПР(F3;B3:B255;1;0)) - достаточно было указать только первый столбец
Страницы: 1
Читают тему (гостей: 1)