Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Расчет зарплат с заданным условием от и до
 
Товарищи, очень нужна Ваша помощь.
Столкнулся с проблемой, есть расчет с суммой продаж от и до с разным процентом от кол-ва проданного пример:
сумма продаж от 100тыс до 200тыс считается по одному проценту
сумма продаж от 200тыс до 300тыс считается по другому проценту.

считаю по формуле: =ЕСЛИ(И(
ничего не получается.

Строго не судите.
Файл для понимания прикладываю.)
Изменено: Riwat - 7 Апр 2015 21:28:09
 
Добавьте в условиях =, вместо >, вставьте >=, чтобы захватить граничные значения.
Неизлечимых болезней нет, есть неизлечимые люди.
 
Исходя из Вашей структуры, как-то так:
Код
=ЕСЛИ(ПОИСКПОЗ(B3;B8:B11;1)=4;20000;B3*ИНДЕКС(D8:D10;ПОИСКПОЗ(B3;B8:B10;1)))



 
Уважаемые TheBestOfTheBest, МВТ, спасибо Вам за помощь.
Весь день думал что не так...
 
Riwat, даже проще, на самом деле:
UPD с учето того, что теоретически сумма сделки может быть меньше 100000, т.е  человек бонуса не заслужил (если правильно понял), то небольшое дополнение
Код
=ЕСЛИОШИБКА(МИН(20000;B3*ИНДЕКС(D8:D10;ПОИСКПОЗ(B3;B8:B10;1)));0)

Изменено: МВТ - 7 Апр 2015 21:53:27
 
МВТ,Спасибо, но так почему то при максимальном значении не выдает этот самый потолок по расчету, а пытается перемножить на процент. Предыдущая формула работает отлично!
завтра сяду изучать индексы))

Спасибо!
 
Вот так, вроде нормально (перемудрил на ночь глядя :))
 
Цитата
МВТ написал:
UPD с учето того, что теоретически сумма сделки может быть меньше 100000, т.е  человек бонуса не заслужил (если правильно понял), то небольшое дополнение
МВТ,да, Вы правы. расчет только от 100 000.

Спасибо за файл, я правильно понимаю если таких у меня 100 человек то ячейки надо закрепить знаком "$" ?
 
А если такой вариант? Постарался предусмотреть возможные вариации.
 
Mykola, спасибо! все доступно, при таком раскладе я могу сам прописывать формулы. ранее не думал зачем в ВПР нужна истина, теперь знаю. Спасибо за советы)
 
Riwat, чтобы не заморачиваться с диапазонами еще немного упростим
Код
=ЕСЛИОШИБКА(МИН(20000;B3*ИНДЕКС({0,005:0,1:0,2:0,4};ПОИСКПОЗ(B3;{100000:200000:300000:500000};1)));0)
При необходимости, в фигурных скобках можете сами дописывать критерии, только так, чтобы и в первых, и во вторых скобках они шли по возрастающей
Страницы: 1
Читают тему (гостей: 1)