Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Перевод секунд в формат Лет,Месяцев,Дней,Часов,Минут,Секунд
 
Добрый день, господа.
Не могу решить задачу, прошу Вашей помощи.
Есть регистр,  в котором фиксируется: дата завершения работы и количество затраченного времени (в секундах) на выполнение работы.
Хочется сделать формат времени отображающий количество секунд, минут,дней, месяцев, лет в одной ячейке.
При подведении итогов понадобятся даже года.
Получилось с помощью =ТЕКСТ(C2/24/60/60;"ч:мм:сс") получить нормальный вид по времени, но если потрачено времени больше 24 часов, он обнуляется и считает заново.

В идеальном варианте отображать "год" "месяц" день" только если количество секунд действительно на столько велико.


Заранее спасибо за помощь!))
 
Темам следует давать более развернутое название. Исправил.

По вопросу: на глаз - "дд.чч:мм:сс;@" (проверьте сами)
 
vikttur, спасибо!
Подскажите, как добавить месяца и года?
по логике ...C2/24/60/60;"гг.мм.дд.чч:мм:сс;@"... - но в таком случае повторяются данные по минутам т.к. это тоже "мм", а годы выставляются как 1900 и т.д.
Просто к сожалению не хватает размера в 31 день.
 
vikttur, или чтобы считалось бесконечное количество часов или дней не обнулялось на 24/31.
 
Gerasim.a, вы бы в файле показали какие цифры хотите увидеть а то ваще не понятно что за измерение в секундах для чего
моя попытка  
Лень двигатель прогресса, доказано!!!
Страницы: 1
Читают тему (гостей: 1)