Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Поиск максимального значения и определение столбца с этим значением.
 
Сабж. Как вытащить максимальную ячейку из строки и определить какому столбцу она принадлежит?
например имеем:
A B  C  D  E
1  2  5   3  7
5  4  6   1  9
3  8  0   2  6
на выходе получить:
A B  C  D  E  F
1  2  5   3  7  E7
5  4  6   1  9  E9
3  8  0   2  6  B8
etc.
Есть идеи?
Изменено: still25 - 9 Апр 2015 19:01:26
 
=ПОИСКПОЗ(МАКС(диапазон);диапазон)
 
Цитата
still25 написал: ... на выходе получить...
Это с какой стати? Может,  все-таки, E1, E2 и B3?!
См. правила - пример в РЕАЛЬНОЙ СТРУКТУРЕ И ФОРМАТАХ (файл XL)... ;)
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
В первой строке максимальное значение 7, оно принадлежит столбцу E, следовательно Е7. Во второй 9 принадлежит Е => E9, В8...
Зачем загромождать файлами если тут три цифры и полторы буквы
Изменено: still25 - 9 Апр 2015 19:09:28
 
still25, помощь прекращается до исправления замечания.
Правила, пункт о бестолковом цитировании.

Цитата
Зачем загромождать файлами если тут три цифры и полторы буквы
И правильно. Я Вам в сообщении №2 показал формулу. Пользуйтесь.
 
vikttur, Как мне удалить сообщение с бесполезным цитированием?
Не могли бы вы привести синтаксис этой ПОИСКПОЗ? Первый диапазон это строка, а второй?
То есть не синтаксис а конкретный пример
Изменено: still25 - 9 Апр 2015 19:00:14
 
Удалять не нужно. исправьте

Цитата
не синтаксис а конкретный пример
Вы, значит, считаете, что пару ячеек показывать не нужно, но при этом просите подробной формулы...
Правила, п.2.3
 
Цитата
still25 написал: ... определить какому столбцу она принадлежит?
За слова отвечать надо, однако... ;(
Image 077.png (8.92 КБ)
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
vikttur, вот файл
http://dropmefiles.com/aBOFr
можете показать на примере?
 
если нет повторений чисел
Код
=СЖПРОБЕЛЫ(ЛЕВСИМВ(ПОДСТАВИТЬ(АДРЕС(1;СУММПРОИЗВ((МАКС(B2:F2)=B2:F2)*СТОЛБЕЦ(B2:F2));2;1);"$";ПОВТОР(" ";3));3))&МАКС(B2:F2)

если есть, то формула массива:
Код
=СЖПРОБЕЛЫ(ЛЕВСИМВ(ПОДСТАВИТЬ(АДРЕС(1;МАКС((МАКС(B2:F2)=B2:F2)*СТОЛБЕЦ(B2:F2));2;1);"$";ПОВТОР(" ";3));3))&МАКС(B2:F2)
F1 творит чудеса
 
Максим Зеленский, спасибо большущее! о повторах я не подумал! уточню
 
Кросс - http://www.excelworld.ru/forum/2-16891-1#140175
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Цитата
Z написал: Кросс ...
Хоть это в правилах не запрещено?
Не думал что мне столько решений сразу накидают, большое всем спасибо!
Изменено: still25 - 9 Апр 2015 20:57:05
 
Цитата
Хоть это в правилах не запрещено?
А сами почитать - никак? Есть упоминание...
 
vikttur, Извините, был напуган!) наш человек берется читать инструкцию если только уже совсем ничего не получается и я не исключение... а вы наверное всегда читаете лицензионные соглашения) Большое спасибо за помощь, правила таки прочитаю.
 
Функции МАКС и ПОИСКПОЗ это то что надо. Но как быть с повторами значений в строке? Если равных максимальных значений >=2, как бы их вытащить?
 
Зачем повторы? Какая разница - будет выведена двойка один раз или четыре?
Может быть, количество считать?
Если нужны номера столбцов - формула массива:
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ($A6:$E6=$F$6;СТОЛБЕЦ($A6:$E6));СТОЛБЕЦ(A1));"")
 
Нормально, да?
Пристает в личке с просьбой о помощи, а в тему заглянуть на протяжении часа - никак?
И помогай таким...
 
Главное определить _к какому столбцу_ принадлежат эти цифры. Например, три одинаковых максимальных в строке значения 130 находятся в столбцах A, D и F. В соответствии с файлом 3222127.xlsx приложенном выше хотелось бы увидеть например три столбца "СТОЛБЕЦ" (G) в случае, если есть повторы, в которых в этом случае будут отображено в каких еще столбцах представлено такое же максимальное значение.
 
vikttur, Спасибо!!!
 
vikttur, помогите пожалуйста расписать словами эту формулу
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ($A6:$E6=$F$6;СТОЛБЕЦ($A6:$E6));СТОЛБЕЦ(A1));"")
она работает, но я не понимаю как
если в диапазоне А6-Е6 значение максимума из F6 то... дальше я потерялся=(
и чем отличается формула массива от обычной? ведь в обычных формулах (не { }) тоже можно брать данные нескольких ячеек

если конечно найдется свободная минутка, а то скажете что я у вас время отнимаю
Изменено: still25 - 14 Апр 2015 14:02:06
Страницы: 1
Читают тему (гостей: 1)