Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Сумма значений в столбцах по условию
 
Добрый день!
Помогите, с формулой, пожалуйста. Во вложении пример. Суть в следующем: есть таблица - в строках названия магазинов, в столбцах названия продукции. Есть флажки, с помощью которых задается, какую продукцию необходимо просуммировать.

Формулу я прописал, но она получается достаточно громоздкая в том случае, если столбцов много. Прошу подкинуть идею, может быть есть вариант проще?

Заранее благодарен.
 
Как-то так
Неизлечимых болезней нет, есть неизлечимые люди.
 
=СУММПРОИЗВ(ИНДЕКС($B$2:$E$5;ПОИСКПОЗ(A13;$A$2:$A$5;);)*$B$7:$E$7)
 
А ведь можно и проще (к файлу в сообщении №3):
=СУММЕСЛИ($B$7:$E$7;ИСТИНА;ИНДЕКС($B$2:$E$5;ПОИСКПОЗ(A13;$A$2:$A$5;);))
Или так, как в прикрепленном файле.
 
=СУММ(МУМНОЖ(Ч((A12=$A$2:$A$6)*ТРАНСП($J$1:$J$4)*$B$2:$E$6);ТРАНСП($B$2:$E$2)^0))
"..Сладку ягоду рвали вместе, горьку ягоду я одна."
 
Может сводной таблицей?
Страницы: 1
Читают тему (гостей: 1)