Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Можно ли преобразовать формулу что бы код ошибки был пустой ячейкой?
 
Формула =НАИБОЛЬШИЙ(Лист1!A$1:A$8;A1) ругается на пустые ячейки кодом:#ЧИСЛО! Можно ли преобразовать формулу так, что бы код ошибки формулы: #ЧИСЛО! был равным значению пустой ячейки ""
 
Пробывал вставить функцию ЕСЛИ() ... увы не получается к сожалению
 
ivanuch, используйте еслиошибка(формула;"")
Лень двигатель прогресса, доказано!!!
 
Цитата
Пробывал вставить функцию ЕСЛИ()
А показать? Наверное, плохо пробовали.
=ЕСЛИ(СЧЁТ(Лист1!A$1:A$8)...;...)
 
Варианты Еслиошибка и если(Еош и Индекс без ошибок
Лень двигатель прогресса, доказано!!!
 
Сергей, =ЕСЛИ(ЕОШ(НАИБОЛЬШИЙ(Лист1!A$1:A$8;A3));"";НАИБОЛЬШИЙ(Лист1!A$1:A$8;A3))
... работает ... и так просто ... спасибоооооооооооооооооооо ....
 
Зачем вычислять НАИБОЛЬШИЙ в каждой формуле? В отдельной ячейке счет значений и сравнение с этой ячейкой.
 
vikttur,
Столбец с этой формулой есть промежным значением для другой задачи: поиск наибольшой 1 серии, 2 серии, 3 серии и так далее с помощю формулы масива що мне здесь на форуме сообразили:{=МАКС(ЕСЛИ(СЧЁТЕСЛИ(C$1:C$20;C$1:C$20)>=СТРОКА();C$1:C$20))}
 
Тем более нужно облегчать вычисления. если в формуле массива записано один раз НАИБОЛЬШИЙ(диапазон;СТРОКА(1:15)), это не значит, что вычисления прошли один раз.
Страницы: 1
Читают тему (гостей: 1)