Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Поиск данных по заданному условию
 
Доброго времени суток!
Подскажите пожалуйста кто знает где почитать или как сделать данную задачку:
Есть 2 колонки с данными А и В:
           А                        В                            C                     D                      E
1
2    Организация        Организация                                  Сидоров Ю         Данные 3
3                                                                                     Иванов А           Данные 1
4    ФИО:                   ФИО:
5    Иванов А              Петров В
6
7    Данные 1             Данные 2
8
9
10  Организация        Организация
11
12  ФИО:                   ФИО:
13  Сидоров Ю          Макаров Г
14
15  Данные 3             Данные 4
16
17
18  Организация        Организация
19
20  ФИО:                   ФИО:
...и. т.д. список большой

мне необходимо к списку фамилий в колонке D, подтянуть "Данные" из этого массива, которые расположены на 2 строки ниже фамилий в колонку E.
Проблема в том, что сортировки нет и она не возможна.
Буду рад вашему ответу ))
 
Вот пример файла, а то что то всё творчество съехало ))
 
как-то так
Код
=ЕСЛИОШИБКА(ИНДЕКС(A:A;ПОИСКПОЗ(D2;A:A;0)+2);ИНДЕКС(B:B;ПОИСКПОЗ(D2;B:B;0)+2))
 
Спасибо огромное!! )) а я пытался в одну кучу слить обе колонки )
 
формула массива
Код
=ИНДЕКС($A$2:$B$84;СУММ(ЕСЛИ($A$2:$B$84=D2;СТРОКА($A$2:$B$84)))+1;СУММ(ЕСЛИ($A$2:$B$84=D2;СТОЛБЕЦ($A$2:$B$84))))
F1 творит чудеса
Страницы: 1
Читают тему (гостей: 1)