Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
сколько понедельников в столбце, сколько дней недели в столбце
 
Здравствуйте, помогите разобраться, у меня есть колонка с датами 01.01.13, 03.01.13 вот в таком формате.
как мне посчитать сколько понедельников в этой колонке?. также вторников  и тд...
спасибо.
 
возможно нужно из каждой ячейки извлечь конкретный день, а потом посчитать....
 
Вариант: вывести в соседний столбец день недели и по нему СЧЁТЕСЛИ
 
Юрий М, Здравствуйте, а как вывести? я попробовал =ТЕКСТ(А1;"ДДД") но у меня есть и пустые ячейки в столбце, так вот формула в них считает как *суббота*, хотя там пусто...
Изменено: Muzalevskiy - 11 Апр 2015 23:40:54
 
=ДЕНЬНЕД(A1;2)
 
Функция ДЕНЬНЕД(ДАТА;2). Второй аргумент - 2, чтобы день недели нумеровался от понедельника к воскресенью 1-7
 
ничего не получается, у меня колонка начинается в ячейке L10, сначала не тот день писал, потом поменял с 2 на 1. дни стали совпадать как надо, но в столбце есть пустые ячейки, и в них то формула снова считает субботу
 
Ну так сделайте проверку:
=ЕСЛИ(L10=0;0;ДЕНЬНЕД(L11;2))
 
=ЕСЛИ(L10="";"";ДЕНЬНЕД(L10;2) Еще раз: при втором аргументе = 2, понедельник - 1, воскресенье - 7
Изменено: МВТ - 11 Апр 2015 23:52:42
 
я скинул файл, посмотрите пожалуйста, формула считает пустую ячейку за субботу!(((
 
Вы упорно даже не пытаетесь читать то, что Вам пишут? В третий раз (см. 8 и 9 сообщения): используйте функцию ЕСЛИ(). Конкретно для Вашего примера она будет выглядеть так:
Код
=ЕСЛИ(L10="";"";ТЕКСТ(L10;"ДДД"))

 
все получилось. спасибо МВТ, ДДД было определяющим.
 
ну так как вариант без доп столбца
Лень двигатель прогресса, доказано!!!
Страницы: 1
Читают тему (гостей: 2)
Наверх