Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Поиск дублей с учетом даты
 
Уважаемые знатоки!

Помогите с казалось-бы простой задачей - выделением дублей с учетом даты.

Есть таблица со списком значений.
Периодически (в разные даты) идентичные значения могут появляться в таблице.
Нужно для "старых" одинаковых значений делать пометку "дубль", при этом последнее по дате идентичное значение отмечаться как "дубль" не должно.

p.s. Раскраску в примере я сделал просто для наглядности, нужно просто выявить дубли (да/нет)
 
Скажите, а даты неотсортированные, как в примере, или они как-то упорядочены?
Кому решение нужно - тот пример и рисует.
 
если надо выделить дубли кроме последнего не обращая внимания на даты то так можно
Код
=ЕСЛИ(СЧЁТЕСЛИ($B$2:B2;B2)=СЧЁТЕСЛИ($B$2:$B$23;B2);"";"дубль")
Лень двигатель прогресса, доказано!!!
 
Монструозно получилось:
Код
=ЕСЛИ(НАИБОЛЬШИЙ(ЕСЛИ($C$2:$C$23>1;($A$2:$A$23)*($B$2:$B$23=B2);"");1)=A2;"нет";ЕСЛИ(НАИБОЛЬШИЙ(ЕСЛИ($C$2:$C$23>1;($A$2:$A$23)*($B$2:$B$23=B2);"");1)=0;"";"да"))


формула массива
Кому решение нужно - тот пример и рисует.
 
Спасибо Пытливый!, формула массива работает (жалко только что массив). Даты могут быть неупорядочены

Сергей, даты - это обязательный аргумент. p.s. Полностью согласен с подписью :)
 
Пытливый, подскажите, как изменить формулу если нужно искать первое значение (самая ранняя дата), а для всех последующих ставить "Дубль"
 
Формула массива
для последнего {=ЕСЛИ(C2>1;ЕСЛИ(A2<МАКС(ЕСЛИ(C2=$C$2:$C$23;$A$2:$A$23;0));"да";"нет" );"" )}
для первого {=ЕСЛИ(C2>1;ЕСЛИ(A2>МИН(ЕСЛИ(C2=$C$2:$C$23;$A$2:$A$23;МАКС($A$2:$A$23)));"нет";"да" );"" )}
 
Цитата
Михаил Лебедев написал:
Формула массива
для последнего {=ЕСЛИ(C2>1;ЕСЛИ(A2<МАКС(ЕСЛИ(C2=$C$2:$C$23;$A$2:$A$23;0));"да";"нет" );"" )}
для первого {=ЕСЛИ(C2>1;ЕСЛИ(A2>МИН(ЕСЛИ(C2=$C$2:$C$23;$A$2:$A$23;МАКС($A$2:$A$23)));"нет";"да" );"" )}
Михаил, первая формула у меня уже была, а вот вторая (которая и нужна) работает неправильно. Даже те значения, которые не являются дублями (уникальные, представленные один раз) определяются как "да" (т.е. дубль). См. файл "Пример-2"
 
freon, без цитирования никак? Кнопка цитирования НЕ ДЛЯ ОТВЕТА!
 
freon, Вы з понимаете смысл слова ЦИТАТА? Исправьте сообщение. Пользуйтесь кнопкой цитирования по назначению, а не для ответа.
Страницы: 1
Читают тему (гостей: 1)