Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Подстановка значения по двум критериям
 
Добрый день!
Во вложении пример, в интернете описана данная схема по подстановки значения, используя два критерия для поиска.
Но в данном случае постоянно возникает ошибка, скорее всего это связанно с тем, что критериями выступают два числовых значения.
Если возможность как то дополнить формулу или вставить другую функцию для решения данной задачи?
 
Как-то так
Код
=СУММПРОИЗВ(($O$3:$O$18=C3)*($P$3:$P$18=E3)*($Q$3:$Q$18))


 
если вы цепляете для поиска два показателя тогда и диапазон должны сцепить и формула стает массивной
Код
=ИНДЕКС($Q$3:$Q$18;ПОИСКПОЗ(C3&E3;$O$3:$O$18&$P$3:$P$18;0))
Изменено: Сергей - 14 Апр 2015 15:24:53 (файл)
Лень двигатель прогресса, доказано!!!
 
ну если вы искомое значение берете как слияние, то и область поиска представьте так же:

{=ИНДЕКС(Q3:Q18;ПОИСКПОЗ(C3&E3;O3:O18&P3:P18;0))}
Изменено: Слэн - 14 Апр 2015 15:24:12
Живи и дай жить..
 
Формула массива
Код
=INDEX($Q$3:$Q$18;MATCH(1;($O$3:$O$18=C3)*($P$3:$P$18=E3);0))
Страницы: 1
Читают тему (гостей: 1)