Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Несколько диапазонов проверки для выпадающего списка, Как связать правильно несколько формул СЧЁТЕСЛИ?
 
Всем привет.
Использовал вот этот прием с сайта.
http://www.planetaexcel.ru/techniques/1/36/

Очень выручает, НО потребовалась необходимость для проверки взятых значений в нескольких диапазонах.
В примере данные только в одном столбце (столбик "Смен назначено"). В нем вот такая формула =СЧЁТЕСЛИ($B$2:$B$8;E2).

Но я к примеру выбираю смены на несколько дней! То есть мне необходимо 2 и более диапазонов.
Примитивно объясняя это
=СЧЁТЕСЛИ($B$2:$B$8;E2) ИЛИ СЧЁТЕСЛИ($Z$2:$Z$8;E2) (формула неверная, это для того чтобы мысль просто свою пояснить).

Я пытался разными способами, но ничего не получается.
Последнее что вышло это
=СЧЁТ(ЕСЛИ($C$4:$P$10;A4)*ИЛИ(ЕСЛИ($C$14:$P$20;A4)))

Но это тоже не работает. Подскажите как быть? Что я делаю не так?
 
показали бы на примере в файле
Лень двигатель прогресса, доказано!!!
 
Пожалуйста. Столбик "Смен назначено" считает и удаляет людей только если вы их выбираете на первой неделе. А вторую не считает. Надо чтобы считал обе. Ячейки B9 и B10 (белый диапазон) не должны быть задействованы.
 
Тю а зачем вам такие сложности можно просто
Код
=СЧЁТЕСЛИ($B$2:$B$8;E2)+СЧЁТЕСЛИ($B$11:$B$17;E2)
Лень двигатель прогресса, доказано!!!
 
Сергей спасибо огромное!))
Страницы: 1
Читают тему (гостей: 1)